1.6 or 1.8 GHz dual-core processor, 2 GB or 4 GB of SDRAM, 64 GB or 128 GB SSD

152 Questions View all

Installed new battery, but not charging

I recently installed a new (aftermarket) battery in my MacBook Air 11" after the original battery stopped working.

After replacing the battery status reads Replace Now. Not charging.

After some research I decided to replace the i/o board but unfortunately I get the same result.

Suggestions? Should I assume the new battery is faulty? Or should I try replacing the i/o board cable as well?

Update (09/30/2015)

In addition: I have tried two different MagSafe chargers and also reset the SMC twice.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Try a PRAM reset holding alt, cmd and R+P on start up until your hear the chime again. This should enable the macbook to attempt to charge, failing that clean the charger ports well with alcohol using a paintbrush/toothbrush - then try again. This has worked for me in the past. Alternatively you may have a faulty battery - aftermarket ones can occassionally arrive without charge.

Was this answer helpful?

Score 0
Add a comment

Add your answer

MichaelV74 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 122