The LG G4 was released in the US in early June 2015, as always focusing on high-end specifications and a refined fashion sense that makes it stand out in the premium smartphone market. Each version of the phone will have a different model number based on if it is sold by a carrier or sold by LG as a US Unlocked or International model.

75 Questions View all

No flash or rear camera after screen repair.

Replaced the screen on my g4, I fear I may have pulled the camera out tovhard, apps can't detect it and flashlight apps say flash is in use tho it's not on.

Answered! View the answer I have this problem too

Is this a good question?

Score 2

Comments:

Did you ever find a fix to this?

by

Add a comment

3 Answers

Chosen Solution

There may have been damage to the flex cable that connects to the motherboard from the camera. try disconnecting it then reconnecting it. and look for any damage on the camera or on the connector on the motherboard. chances are that is the cause.

Was this answer helpful?

Score 1

Comments:

Hey Candido, I also have a similar problem after replacing the digitizer. I've also bought a new replacement camera but that replacement didn't work either.

One thing I did notice was that I tore the foil tape on the bottom of the original camera; the new camera didn't have replacement foil either. Do you think this would be the root of the problem and if so, where can I buy something like that?

by

Add a comment

I have the same issue,

I toredown a second time the device and check visually the rear camera and saw no damage.

I use the opportunity of this post to ask to Max if you saw a damage to your rear camera ?

You change your rear cam to solve your pb ?

There is any way to check the rear camera alone to check if it works prior to put back on the motherboard ?

Thank in advance for your time !

Cheers,

Was this answer helpful?

Score 1
Add a comment

Hello! I was lucky because the dude that made the repair did not fix the flex cable of the camera to the mainboard corectly. You should check the connections of the flex cable to the mainboard first of all. Wish you luck! Mine works perfectly after fixing the cable. Cheers!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Max W will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 11

Past 30 Days: 39

All Time: 946