Replaced Logic Board and can't get to boot screen. Suggestions?

Ohhhkay. So, I replaced the PowerBook G4 Aluminum 15" 1.67 GHz logic board to resolve unusual screen pattern diagnosed as bad VRAM by TechTools.

Held my breath, plugged it in and restarted tapping the power button. I can hear the drive spin up and then down, I can hear the computer repeatedly accessing the empty CD drive. The caps lock light is operational, the sleep light is glowing steadily but the screen is dark and the computer doesn't boot. I can hear the computer repeatedly accessing the empty CD drive.

So I power down, then restart holding the power button down until I hear the fans blow hard followed by single tone, the sleep button flickers repeatedly for several seconds, then I can hear hard drive spin up, then down but the screen remains black and PowerBook tries to repeatedly boot from CD drive. Again.

So I put PowerBook G4 install disc in and PowerBook tries to repeatedly boot from CD drive, but still no boot up. And, of course, now I can't get the CD to eject. Other than the key caps light, the keyboard and track pad appear unresponsive.

Zapped PRAM, reset PMU, took it apart again, checked all logic board connections, but the same result.

Am I missing something?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

1 beep - did you install the ram????

here is the beep code list from apple:

1 beep = no RAM installed

2 beeps = incompatible RAM types

3 beeps = no good banks

4 beeps = no good boot images in the boot ROM (and/or bad sys config block)

5 beeps = processor is not usable

the sleep light also shows the code - but always plus 1 (1 beep 2 flashes and so on)

Was this answer helpful?

Score 1


Yes, I installed the RAM, which had been previously working on the old board.

To be specific about the beep, when I hold the power button down for three seconds, I then hear a single 3 second tone, followed by very very rapid flashing of the sleep light. About 10 or 12 flashes in 1.5 seconds.

Any idea if these flashes are too fast for beep codes, and if not, does this mean my new board is bad?

I also tried variations to test the RAM banks and the RAM. When no RAM was installed I heard the single beep and double flash as described above, however when either a single chip was in either bank or both chips were in different banks, when I restarted the screen remained off and it would not boot.

Oddly, I heard the happy start up chime only once when only the top RAM bank was in use, but still no boot. I was unable to repeat the chimes again, even after multiple restarts, after holding the power button down briefly to start, or holding the power button for 3 seconds, or while holding option+command+P+R keys.


strange..., i would only try to use the top ram slot, try to disconnect the pram battery and start the powerbook, try to power it on without battery. but to be honest, it doesn't sound good. maybe you should look around for a company that fixes gpu errors. search on ebay for powerbook and gpu - maybe you should get rid of the new. non working board and get the old one fixed


Thanks for the advice Markus. I ended up putting the old logic board back in and it started right up, so it looks like the "new" board has a problem.


thanks for the info, and don't forget to "accept the answer" - this moves the question from unresolved to resolved and can help others


Roger that Markus. A new board's on order. -- By the way, the 3 second tone and rapid flashing was confirmation of a PMU reset rather than RAM status codes.


Show 1 more comment

Add a comment

Add your answer

Glenn Abrams will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,555