Sony Cyber-shot DSC-H200 is a digital camera. This device is capable of taking photos and recording HD video in 720p. The model year for this camera is 2013.

22 Questions View all

Lens is stuck and camera won't turn on properly?

Basically i was using my camera as usual when the picture went extremely blurry. I turned it off to turn it back on again but the lens stayed out, which it has never done before. It now won't turn on properly, it just shows the 'Cyber-Shot' start screen and the lens is still extended. Really need this fixing as my father not long passed away and this was the last birthday present he ever got me and i also make youtube videos, there are many reasons this camera is important to me and i'd really appreciate any help!

Answer this question I have this problem too

Is this a good question?

Score 4
Add a comment

5 Answers

Most Helpful Answer

danaandersen , the reason for this "It now won't turn on properly" is because something is interfering with the lens extension mechanism. Check on here for some more information and potential fixes. Personally I have had not much luck with those and replaced the lenses on cameras. Definitely worth a try.

Was this answer helpful?

Score 5
Add a comment

Hi, i had exact same problem. If reset does not work, try this. When u turn it on can u feel your camera trying to pull lens in? Its part of its start up function. This worked with my wife's.

1. Push on button, and listen.

2. When motor stops and u cant hear it, pop battery and replace fast, and turn on again.

3. Repeat this process a few times, my wife's went in and worked fine on the 4th or 5th try.

Hope this helps

Was this answer helpful?

Score 1

Comments:

I just had that same problem. I turned my cam off, took the battery out & put it back in quick, then turned it on & it was working just fine after that. Hope it works for you.

by

Add a comment

I had the same problem with my Sony a5000. My lens was stuck and the screen on the back was black, even though it would turn on and off. My battery seemed to be overheating, so I took it out for about an hour, popped it back in, and then pressed the Menu button for 5 seconds and then turned on the camera. My problem was solved after that and everything seems to be working fine for now.

Was this answer helpful?

Score 1

Comments:

This worked for me!!! Thanks! :)

by

Glad to hear it worked! :)

by

Add a comment

I have the same problem did you get any solution?

Was this answer helpful?

Score 0
Add a comment

After viewing a video of someone with the same problem, I tried gently yanking on the lens. It worked! It closed itself after a couple of tugs. It's working fine now.

Was this answer helpful?

Score 0
Add a comment

Add your answer

danaandersen will be eternally grateful.
View Statistics:

Past 24 Hours: 33

Past 7 Days: 240

Past 30 Days: 1,117

All Time: 12,814