Files will not transfer!

When I plug my seagate external into my macbook pro I can play and get to all of the files on it but when I try to transfer files on to it it gets half way done and then I get the message "this file is in use by another application" and will not let the transfer go through. The thing is it is not being used by another application, I quite all applications. Then when i try and eject my hard drive I have to force eject it.

Things I have tried:

1. relaunched finder

2. ran both macbook pro and hard drive through disk utility - everything was fine

3. unplugged and replugged my external from both my computer and its power source.

The only thing I can think of is that it fell off my desk a day or two ago about two feet... could that be the reason it isn't letting the file transfer go through?

I also just recently updated my mac, could that also be the reason?

Please help!!!

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Just to double check, you tried "repair permissions" and "repair disk" on that hard drive and it did not help?

by

Yea I already tried that on both the drive and the computer. And it said everything was okay.

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Most Helpful Answer

So it most likely isn't an issue on the drive end. The best way to verify this is if you have a flash drive lying around to try to transfer to that. If you get the same message we will now that your mac thinks this file is currently in use. From that point, if you can copy the file and paste the copy of it to your desktop, you should be able to transfer the copy over to the Seagate with no issues. Let me know if this works and we can go from there.

Was this answer helpful?

Score 1

Comments:

So I can transfer files from my mac to a flash drive but I can't transfer files from a flash drive to my external when both are plugged into my mac. This also happens when I try and transfer files from a different computer to my external.

So is it my external that thinks files are in use?

by

Hmm, it does appear to be the drive then, I would refer to Rany's comment above asking about running repair permissions and repair disk on the drive itself. If you have already done both of those things with no luck, let me know. Is the Seagate new?

by

I have already tried both of those things. It is not new probably around 4 or 5 years old. I also discovered that this only happens when i try to transfer movie files. I can transfer all other documents fine.

by

Have these movie files been played or edited on the computers? If so, what program?

by

They have been played in VLC and quicktime but they have not bee edited. I can't even move video files within the hard drive itself.

by

Show 8 more comments

Add a comment

Add your answer

Laura McConnaughy will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 16

All Time: 694