The Sony Xperia Z is an Android based phone that was released in 2013. It is one of the largest phones of the Xperia family with a 5-inch full HD display. Model numbers include C6603/C6602.

101 Questions View all

After LCD replacement, No Sim/No Service

Hi, I recently replaced the lcd/digitizer display on a Sony Xperia Z for a customer of mine and everything seemed to go fine as usual until I turned the phone on after the repair was done. The phone was showing NO SIM/NO SERVICE. I checked the sim card tray and tried taking it out a few times and even checked to see if it was in the correct way and it was. I opened the up the back of the phone again to check if I'd maybe damaged the antenna wire or antenna board but all looked good and connected correctly. I'm a bit stuck on this one so if anyone has had this problem before or any other ideas they would be very appreciated. Thanks

Answer this question I have this problem too

Is this a good question?

Score 8

Comments:

(1/2)

Hey Hi. I have Sony M4 Aqua Dual (E2363). Recently I have replaced my broken screen. While replacing the shop guy who is replacing my screen said that, "the board which has MIC and antenna was also damaged. If I remove the back cover, the board may crack. If it happens so, New board should be installed". Unfortunately my bad luck the board damaged while replacing. So, he ordered new MIC/Antenna Board which costs around 1400 Rs. He installed that thing. After that i found poor network connection. My friend is using same mobile and same network service provider (Airtel and Aircel) as me. He is getting Full signal (GSM Signal) where i am receiving 1 point or nothing. If I switch to WCDMA/LTE i am getting 75% signal as my friend is getting. If he Gets full WCDMA/LTE signals, I may get 1 or 2 point lesser than him but not full as him. I went to the shop which i have replaced the screen and antenna, filed a complaint about the faulty board.

by

(2/2)

He checked and accepted the faulty board and replace the new MIC/Antenna board. But still am facing the same issue. Inside the Roof/Room, i am not getting signals. But If I am going out, (If my mobile faces the sky) I got signals, but not as my friend's signal. He is getting full GSM/WCDMA/LTE outside the roof. I am getting 1 or 2 point lesser sometimes full. I have done facory reset. Later I have flashed my mobile with stock Marshmallow. Then with Stock Lollipop. Still same problem. And forgot to add this thing. I found my vibration motor is not working. I dont know, when this problem starts. Hope, it joined the queue after replacing that board. Shop keeper is saying, "we can try TRACKING." I haven't heard this term before. He explained the term. He will remove the MIC/Antenna Board connector pin which seats in the main board and he will do solder between the two borads instead of connecting pin. I dont know how it works. Any suggestions and helps are heartfully appreciated.

by

Add a comment

14 Answers

Most Helpful Answer

Hello!

I have the same issue. I've already replaced the antenna cable running alongside the battery but it didn't work... Did someone of you solve this problem?

Was this answer helpful?

Score 1

Comments:

Have you tried your sim card in another phone to know if its not the problem . look for wear spots on the sim card this can also be a problem . finally try someone else sim card in your phone . If theys no joy here look at the sim slot and inspect the pins that make contact with the card itself. there should be six and all should make contact with the card . All should be straight and not bent sideways

by

Hey man did you manage to fix it?

by

ya i had done it i had changed center body and it is done

]

by

Add a comment

Hey Guys

Here is what I got from Sony Customer Support, I hope it helps

Thank you for contacting the Sony Xperia support centre.

We are sorry to hear you are facing issues with network signal/connection on your Sony Xperia Z1 handset.

We would suggest that you try to perform a repair of the software using Xperia Companion. If the issue is related to a problem with your software this will be repaired and your handset will work as intended.

In order to first backup your data using Xperia Companion, please follow the steps below:

You will need to install Xperia Companion from the Sony Xperia website, the application is available for both OSX and Windows based systems. You can download each from the following links:

Windows/PC - http://support.sonymobile.com/global-en/...

OSX/Mac - http://support.sonymobile.com/global-en/...

1. Open Xperia Companion and select Backup on the dashboard of Xperia Companion.

2. Xperia Companion will now prompt you to name the backup, if there is an existing backup available, the data will be added to this file.

3. You will now be able to select which data you wish to back up, once you have selected this, please click 'Next'.

4. Xperia Companion will request a password to be set up for the backup files. This is optional unless the device is encrypted.

Your backup should now begin, Xperia Companion will notify you when the backup has been successful. Once confirmed, press OK and the process will be complete.

To restore a backup, please follow the below steps:

1. From the dashboard in Xperia Companion, please select 'Restore'. This will then take you to the next page where it will show any files that are compatible with the connect device.

2. If a password was set up during the backup process, the application will prompt to enter the password.

3. You can now choose what data from your backup that you wish to restore.

Please be aware that the data restored will replace the current content on the device.

Xperia Companion will begin restoring the data to your handset and will notify you when the restore has been successful. Once confirmed, press OK and the process will be complete.

To then perform the software repair of the handset, please follow the steps below.

Please make sure that at the start of the process the device is turned off and disconnected from the computer, then:

1. Open Xperia Companion

2. Click Software Repair

3. Some on screen steps will now appear for you to follow. Please do not connect the handset until you are prompted to do so.

4. When you are asked to connect the handset (still with the phone powered off) please press and hold the key stated on screen for 30 seconds before connecting the handset and keep it held down as you connect

5. The repair process should now begin.

Please ensure your handset is not connected to your system when performing the above as you will be instructed to connect your handset once you have followed the above steps. Your handset must also remain powered off at all times.

Please note it may be the case that user data is lost during this upgrade. We therefore recommend backing up any data to your SIM card, Memory Stick, or system before upgrading.

Please be aware that if an update to a later version of Android has become available for your Sony Xperia handset the new version may be installed. If this is the case you may notice some differences

in the functionality of your handset when updating. All information regarding these changes can be viewed on the following link. We would recommend reading through the following before updating:

www.sonymobile.com/gb/software

Was this answer helpful?

Score 1
Add a comment

You won't find much support for an Xperia Z I'm afraid.

I would check to see if you have damaged anything on the logic board

I've only repaired a few, there's not much that can go wrong.

I would direct you to a forum called gsmhosting, they know everything about the hardware etc.

Was this answer helpful?

Score 0
Add a comment

hi craigd24, i had thesame problem of yours.. i would like to ask if already solved the problem? until now i am suffering of this problem.. hoping you already fixed the problem and share it to me.. wiil be so very appreciate if you share to me.. god bless. thanks in advance

Was this answer helpful?

Score 0
Add a comment

i also have this problem. i replaced my screen and lcd and once the phone was back together i now have no signal. the phone was fine before doing the screen change, we even changed the antenna wires and still the same? has anyone managed to sort it?

thanks

Was this answer helpful?

Score 0
Add a comment

The next thing I would try would be a factory restore. Disconnecting the battery or disconnecting other things without disconnecting the battery can sometimes do funky things. I have not worked on a Sony but I have had similar issues on other android phones and doing a factory restore sometimes restores network connectivity after repair when no physical problems with the antenna, etc, can be identified. Be sure to backup any necessary pictures, contacts or files first since a factory restore erases everything and puts it back to the way it was when you bought it new.

Was this answer helpful?

Score 0
Add a comment

Did you guys resolve this issue? I tried replacing everything and it still doesn't work.

Was this answer helpful?

Score 0

Comments:

Hey Teckerz, I could not manage to fix this issue yet.

I only know, that somehow my antenna is broken but not the mobile network module. When I am close to a base station I receive a weak signal. Everywhere else I receive nothing...

by

So many people has the same problem here, I want to know aswell?!

by

Add a comment

Same issue on a customer's phone. SIM works in other phones, so that's not the issue. Nothing is damaged. Following for hopeful resolution.

Was this answer helpful?

Score 0
Add a comment

After many tests I confirm that the issue comes from the antenna cable wich is micro-coax and very easy to break.. Please try to change it !

Was this answer helpful?

Score 0

Comments:

Hello pallouche, I already replaced my antenna cable and tested the new one using a continuity tester. Could the cable still be broken?

by

Add a comment

Yes I finally received the replacement antenna cable... and it works after I replaced it! Signal is not as strong as it used to be but at least it's working now and I'm able to make calls etc. I previously also replaced the antenna module, not sure if it was necessary... but good luck all! :)

Was this answer helpful?

Score 0

Comments:

Hello Teckerz,

which antenna module did you replace? I already replaced the antenna cable and the whole module containing the vibration motor and speaker, but I still have no signal :(

by

Hi Matthias,

I've attached a link below FYI. I replaced the antenna board because I damaged the round connector where the antenna cable is supposed to be connected to. I did not suspect the antenna cable to be the problem since there's no sign of damage, but somehow it did the job. By the way my phone is actually the Xperia Z3, but I believe it should be the same for all Xperias Zs... Let me know how you go?

http://i.ebayimg.com/00/s/NTAwWDUwMA==/z...$_12.JPG

by

Add a comment

Hi,

have the same issue on Z2a, which is unfortunately quite different from Z2 and nobody around wanted to service that phone. I needed to change the battery (the original was gone after year and half) so I managed that on my own. The original battery was heavily glued to the logic board (however it's hold on place by the frame and the glue is useless - except to make it hard to replace...seems those devices are build to last the same time as the battery and than you should buy a new one...). Anyway I succeeded with the replacement but when re-assembled again the signal is completely lost (SIM still accessible), antenna and connection to the logic board seems to be fine, nothing damaged, there're no coax cables on Z2a for antenna connection. Factory reset did not helped and I'm not in mood to wait (and pay) several weeks for new antenna/logic board as it seems I broke something when removing the original battery .....

Was this answer helpful?

Score 0
Add a comment

I am having this problem with my Z5 and don't want to replace the cable if it still won't work

Was this answer helpful?

Score 0

Comments:

I need help i got the LCD replace on my Z5 and no get the no service and no signal. Please help

by

Add a comment

hy i have sony xperia z phone but phone in only one problem o i am put sim in the phone this show emargesey call i call this any no. show mobile network not avalbale how this solusation

Was this answer helpful?

Score 0

Comments:

You could try to replace the antenna cable alongside the battery or the antenna board on the lower part of the phone (close to the speaker). But for me neither of these solutions worked. So I eventually switched to the OnePlus 3T and am happy again ;)

by

Add a comment

If you have bought the lcd with frame, it's the frame. The original one has some contacts which transfers the signal through the body to the bottom. If it doesn't have these contacts on the new frame, you'll get very low signal(actually you will only have signal on open spaces with a nearby antenna)

If not, there are 2 culprits: One is the antenna cable, and the other is the small chip that the antenna cable connects to the bottom of the phone.

Was this answer helpful?

Score 0

Comments:

Beware! No sim and no service are 2 completely different problems! Does the phone recognise the sim?

by

Add a comment

Add your answer

craigad24 will be eternally grateful.
View Statistics:

Past 24 Hours: 16

Past 7 Days: 116

Past 30 Days: 313

All Time: 8,934