The Mac Pro First Generation is an Intel Xeon-based workstation computer manufactured by Apple Inc. between the years of 2006 and 2013.

259 Questions View all

Upgrade to 10.10.2 worked, now disk is not seen as bootable?

Mac Pro (Early 2008)

I started with my Mac Pro and multiple drives installed internally. Two of those drives were bootable, one with OS X 10.5.8 and another with OS X 10.6.8. (I need the older OS for the sake of one lingering application which I need and which cannot run on newer OS's)

I updated the disk containing OS X 10.6.8 to OS X 10.10.2.

I was running this machine from the updated OS successfully for a day or two. I was able to shut down, restart and continue without any issues.

Here's where my trouble began (as I understand it).

I opened System Prefs and chose the older (10.5.8) disk as startup, then restarted from that disk successfully. I worked with the machine for a while then proceeded to try and switch back to the newly updated (10.10.2) disk. When I opened the Startup Disk control panel it did NOT show the drive which contains the new OS, only the disk with the older OS (currently running the machine).

Since then I have been unable to get this machine to recognize the disk which I had updated to 10.10.2. It never shows up as an available option in the Startup Disk control panel. The drive IS mounted on my desktop and I can access it, but it doesn't present as an option to start from.

I've run Disk Utility on the updated drive and it reports that the disk is in good condition, no issues.

I'm not sure what to do next. I'm imagine I could wipe the disk entirely and start over again from Snow Leopard but I really don't want to go through the lengthy hours required for reinstalling my applications and such. I do have my data backed up so I have no worries in that regard.

Your suggestions are greatly appreciated!

Gary

PS - I did search this forum for solutions but could not seem to find any.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

Lets start with a different method to switch disks than using the control panel method. Here's the Apple T/N that goes though the different keyboard controls: Startup key combinations for Intel-based Macs. What we want to use here is the Option key to gain access to the Startup Manager. You should be able to gain access to your other drive that way. If not you may need an external FireWire drive which is setup with a newer OS

Once you get the Yosemite running:

I would start by making sure the systems firmware was upto date. Follow this Apple T/N: EFI and SMC firmware updates for Intel-based Macs.

Given the age of your systems age you may need to redo one or more of your other disks. You see Apple altered the way the disk was setup: GUID & Mac OS Extended (Journaled). Use Disk Utility to see if the disk is correctly setup. If I remember correctly I think it was Leopard that was the time point of the change and Snow Leopard you needed to be at the newer drive setup (it had a drive upgrader during the install/upgrade process).

Also, did you boot up under a different drive to run Disk Utility. Remember you can't really fix a disk that is the booted drive or has anything running on it.

Was this answer helpful?

Score 2

Comments:

Thank you for your response as it is very helpful!

I've restarted my Mac Pro using the Option key and did in fact get access to the Startup Manager. Disk with OS (10.10.2) is listed & I can boot into it! YAY!!

Executing restart while running the new OS reboots to the older OS on the other internal disk. Once there I opened Startup Manager CP and find the disk with new OS NOT listed.

I restart with Option key and can select & reboot to the new OS. Once there I opened Startup Mgr CP and select the new OS there (already running). Simple restart & the machine reboots to the new OS. Great!??

It seems, the only way to reboot from old OS to new OS (I can access the disk and files, I just can't reboot to it) is to restart with the Option key.

System firmware is current.

When I ran Disk Utility with the machine booted from my Snow Leopard install disk.

Sorry, for some reason this comment UI isn't breaking my message into paragraphs...

by

Still puzzled why Startup Manager CP doesn't recognize the disk with OS 10.10.2 while I can boot to it with the Option key?

I have four disks installed internally on this machine, all Mac OS Extended (Journaled).

Would it make any difference which bay is being used? The disk with OS 10.10.2 on it is in bay #4 and is the largest capacity (1TB) of the four disks.

by

Are your disks setup with GUID?

by

Hmmm, it looks like no. I didn't really know what that was so your question pushed me to do a little digging. I still don't really know much about it but based on the screen shot here, http://steadmantechcms.com/Zoom-Zoom.png showing the Disk Utility output from the disk where 10.10.2 is installed I'm guessing not. All four disks show similar results with UUID but no evidence of GUID.

What does that mean?

by

Using Disk Utility, click on the physical drive icon. Look at the bottom right this is what each disk should look like: Partition Map Scheme : GUID Partition Table. Is that what your disks look like (all of them)?

by

Show 4 more comments

Add a comment

Add your answer

Gary Steadman will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 25

All Time: 1,318