Repair and disassembly guides for AirPort Extreme routers.

92 Questions View all

Why won't iMac intel automatically join airport xtreme network?

My downstairs iMac intel used to automatically join my airport extreme network at home (Airport Extreme Base Station with 802.11n, version 7.4.2).

For the past few months, however, the downstairs iMac no longer joins automatically. After it falls asleep, the connection is lost, until I manually select the network, which takes a long time to show up.

There have been no changes in our local equipment.

Nor have there been any added appliances or furniture moves that would create an obstacle or interference.

I have a Time Warner Cable router for internet access, an airport extreme base station attached to it, and in the house we have as other equipment accessing the wifi (no more than two at a time): upstairs an iMac (2.33 GHz Intel Core 2 Duo), plus a MacBook Pro, a MacBook Air, and two iPod touch.

Answered! View the answer I have this problem too

Is this a good question?

Score 0


Thank you, Tesserax, for your suggested solution.

I went through the steps this morning, and everything seemed to be working fine - it made perfect sense to me that your solution should work, since a similar process always works when the printer loses contact (deleting printers and adding them again).

For several hours the airport connection held strong. However, I just checked now, at 7pm, and at this point it is not linking up to airport automatically.

I restarted again, and it is clearly searching for the signal, but it fails to connect on its own. I have to do it manually, by dragging down the airport menu bar icon, and waiting for the network to appear, then selecting it.

If you have any other suggestions, I'd appreciate the help.


The next thing I would try would be to create a new user account. Log-off of the current account, and then, log-on with this new account.

Finally, it that doesn't resolve the problem, try the following:

We are going to temporarily move the Mac's network configuration files. We are doing this to verify that they are not corrupted.

1. Go to /Library/Preferences (Note: This is the system library folder, not the library folder in the user home folder.)

2. Move the SystemConfiguration folder and file to the Desktop.

3. Restart your Mac. (Note: OS X will rebuild the files that are now sitting on the Desktop. If this doesn't resolve the issue, you can simply move the folder and plist file back to their original location.)


I tried the first solution - add a new account - and airport immediately responded. I tried shifting in and out of the two accounts, and reached a point where airport disappeared again.

I followed your second suggestion. I went through each step, but I note that I have no in the system library preferences folder - or anywhere else on the computer. I wonder if that could be the problem?


The fact that you were able to get access to the AirPort with a new user account, would indicate that there may be something missing or corrupt with one of the AirPort configuration files. The "" file may not be available in all versions of OS X. For example, I am currently using Snow Leopard and it doesn't show up on my Mac either. Regardless, the important thing was to move the SystemConfiguration folder to the Desktop. Did you get an opportunity to do so ... and did it resolve the issue?


I apologize for not fully describing all of my steps.

I did move the System Configuration folder to the desktop and restarted the computer. Now, every time it starts up it tells me it cannot find the preferred network (although it is showing it as available in the very same error message). I have to manually select it and enter the password for it to work.


Show 2 more comments

Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Chosen Solution

Try the following:

1. Delete Preferred Network(s)

o System Preferences > Network > AirPort > Advanced > AirPort tab

o Under "Preferred Networks," delete the network(s) you regularly use from the list.

2. Delete AirPort Keychain Entries

o Launch the "Keychain Access" application located in Applications/Utilties.

o Click on the "Kind" filter at the top, and look for any "AirPort network password" entries...and delete them.

o Restart, or log out then back in.

3. Add Preferred Network(s)

o System Preferences > Network > AirPort > Advanced > AirPort tab

o Add the preferred network(s) using the "+" button.

o Restart or log out then back in.

Was this answer helpful?

Score 1


This is a very good process to follow for this issue. +1


Add a comment

Add your answer

Eleanor Dozier will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 2,033