Released September 2013, identified with model number T100T. 2-in-1 portable with Quad core Intel® Atom™ processor and 2GB of RAM.

79 Questions View all

Why is there no display on screen, only backlight?

Hello,

I have replaced my ASUS T100 screen. Now it shows no display when turning it on, only backlight. I have tried adjusting the Ribbon Flex Cable (lcd to mb) to no avail. It only adjusts the brightness of the backlight.

It cost a lot to purchase and replace the screen, lcd and motherboard (other issue), and now it won't even turn on.

Any help or tips would be highly appreciated!

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

More than likely it's your single cable that goes to the LCD screen. Mine is loose after assembling and It keeps doing this too, and I might just end up selling the parts and start with a new one lol.

by

Hey thank you very much for your reply. I have tried adjusting and readjusting the lcd cable and it won't budge = just turns on backlight. I have tried presisng it down with double sided tape and many other attempts. Should I purchase a replacement lcd cable?

by

Add a comment
Deck the Halls
With tools and Fix Kits

2 Answers

Most Helpful Answer

Hi Dalia, You can try to reset the T100. A lot of times after a screen replacement, the BIOS has to be reset in order to register the new screen. To do this, hold the volume up button and the power button until the screen flashes. This should reset the T100 and it should boot up after that. Sorry if this answer is too late for you.

Was this answer helpful?

Score 1

Comments:

I ran into this same issue and followed these steps and sure enough the screen powered up! Thank you!

by

I replaced my digitizer and now it wont turn on the lcd any more is it becouse of the ribbon cable or is it a diffrent issue?

by

I have the same problem, resetting the BIOS didn't help unfortunately. I can only use the transformer pad if I connect it to an external monitor. So computer works, no display on pad though.

Any idea anyone?

by

Add a comment

i have the same issue. i replaced the screen of my t100ta-c2-edu and was super careful with all the hardware. the backlight comes on but theres nothing on the screen. I've re-seated the MB, video and battery cables a few times and they're all connected tightly. I've tried this key combination and others I've read about and i cant get anything to display. it was working fine before the screen was replaced. i hate to think this thing is now a paper weight but thats the way its looking :( any ideas?

Update (10/25/2017)

UPDATE: so the most insane thing I've ever seen and experienced in my IT career - the tablet needs to have the back cover on it in order for it to work. In my case anyway. I left the back cover off cause i wanted to make sure it was going to work before i snapped the cover on. I had given up on getting this to work after replacing the screen and trying everything i saw on the web to get it to show something on the screen and i snapped the cover back on and on a whim pressed the power button and it came on! nuts crazy. works like new. and ASUS wanted me to send it in for a $350 repair. no sir.

Was this answer helpful?

Score 0
Add a comment

Add your answer

EE2 will be eternally grateful.
View Statistics:

Past 24 Hours: 7

Past 7 Days: 33

Past 30 Days: 93

All Time: 3,700