Repair and troubleshooting information for the Suzuki FA50 Moped.

71 Questions View all

no acceleration,starts hard,need help

Bike starts hard and bogs on accelbcleaned carb,good spark etc...

Please help.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

8 Answers

Most Helpful Answer

How old is the gas in the tank ?

is it ready mixed or does the oil pump work (is the oil tank full?)

if the gas is older - change it, use the ready mixed one.

Was this answer helpful?

Score 2
Add a comment

I had the same problem, turns out the exhaust was plugged.

the previous owner was running with oil in oil tank AND premixed fuel creating quite a carbon deposit in the exhaust and oil. Cleaned it with a wire coat hanger and burned out the rest.

Was this answer helpful?

Score 2

Comments:

A clogged exhaust will make you think the motor is being choked . It actually is being choked , just from the wrong end . ;)

by

Add a comment

Could be that you are running super rich on your fuel/air mixture. Try leaning it out.

Was this answer helpful?

Score 1
Add a comment

You shoulddefinitely adjust the idle and air mixture screws if your FA50's not running well. Take a look at the carburetor diagram and make sure that the air mixture screw is 1 3/4 turns, as instructed, and that the idle screw is adjusted properly.

Honestly, I wasn't able to figure out how to set the idle to "1500 +/- 150 RPM," so I just ran the bike until warm and then adjusted the screw until it "sounded right" -- whatever sounded like it should be going at.

Also, make sure that the choke cable is completely off when running the bike, and especially while adjusting the idle / air mixture screws.

Was this answer helpful?

Score 1
Add a comment

you might want to check the compression. it should be between 100 to 125. if its low rebuild is in its future.

nick

Was this answer helpful?

Score 1

Comments:

Mine was 30 so I put a bore kit on it now I'm rebuilding the carb because it sat for 5 months

by

Add a comment

Make sure your transmission oil is clean if the acceleration is bad after you adjust the mixture. You'll be amazed how much this can slow you down.

Was this answer helpful?

Score 1

Comments:

Clean AND the correct oil as recommended in the manual .

by

Add a comment

If it smells rich you may want to change the spark plugs. Easy to do and should be done before mucking around with carby mixture. If you have had bad fuel your spark plugs suffer.

Was this answer helpful?

Score 0
Add a comment

What is the trannys fluid? And recommend oil? Any 2 stoke oil?

Was this answer helpful?

Score 0
Add a comment

Add your answer

darren will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 10

Past 30 Days: 47

All Time: 5,751