Skip to main content

Fix Your Stuff

Right to Repair


Released June 2009 / 2.53 GHz Core 2 Duo Processor

195 Questions View all

MBP extremely slow after SSD Upgrade. What's wrong with my mac?

I have a MPB 15" 2.53 mid 2009. I upgraded the standard hard drive to a SSD (512 GB Sandisk X210) purchased from ifixit.

I cloned the factory drive to the SSD using Super Duper. After cloning the HDD to the SSD I installed it and turned it on, it booted up fine but not quite as quickly as I would expect for an SSD.

Verified and reparied disk permissions.

Restert. Boot up time about 1 minute 20 seconds.

Shut down.

Reset PRAM

Boot up about 1 minute.

Restart. Boot up time about 43 minutes.

I have no idea what happened in the middle there but something is obviously not working right. Now when I click on applications they go gray then take several minutes before launching. I'm not sure what to do. Please help!

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment

5 Answers

Chosen Solution

The internet had the answer for me. Apparently your startup disk setting is pointing to a disk that's no longer in your system. I'm guessing the OS can't find it and is waiting for it to spin up. It doesn't try the new SSD until a timeout occurs.

Go to system preferences and set your Startup Disk setting to be the new disk and I'll bet that changes everything. It did for me.

Was this answer helpful?

Score 13


Good catch!!


It also works for me. I had before for the long time just the white screen before apple logo comes on.


It worked perfectly!

I had the same problem when I upgraded my original 128GB SSD with one of 256GB from Transcend. I couldn't understand why the new SSD had added 10s of grey screen on startup before the Apple logo appears.

So I follow these steps and all started working perfectly again:

1. Go to System Preferences -> Startup Disk

2. Click on the bottom left Lock tu unlock the changes

3. Select Macintosh HD (it's likely to be the only on the list)

4. Click 'Restart...'

You're done!


Thank you so much! Its working!!


Thanks!!! Worked for me!!!


Show 3 more comments

Add a comment

Solved!! - I had almost exactly the same symptoms with my 2011 MacBook Pro. SSD upgrade Super fast for a month, then suddenly became slower than ever. Symptoms included unable to keep up with keystrokes (really annoying), slow application loads, slow printing.

I tried just about everything suggested on the internet; Reset PRAM, SMC, the wear levelling (TRIM). Reinstalled a clean OS (Lion, Yosemite, and El Capitan). Nothing made the slightest difference. I bought a different drive (i had a samsung EVO) I read the OWC were change.

Then one day the mac failed to find my hard drive. I was pretty ticked off by now. So my research for this problem went down a different road. And I ended up buying a replacement SATA cable MacBook Pro 15" Unibody (Mid 2009-Late 2011) Hard Drive Cable Fixed it completely - Mystery solved.

So if this post helps just one person avoid six months of torture I will be delighted.

MacBook Pro 15" Unibody (Mid 2009-Late 2011) Hard Drive Cable Image


MacBook Pro 15" Unibody (Mid 2009-Late 2011) Hard Drive Cable


Was this answer helpful?

Score 5


Man, you've just saved my brain. I was suffering of the same issue during the last month. I've tried almost everything you've tried, but only cable replacement helped.


I had the same problem. Replaced 3(!!!) SATA cables. No joy at all. Ended up with installing back an old good HDD. My old MacBook Pro 13" Late 2011, works fine again.


@ Rob Fox-- so installing the new SATA cable was only a temporary fix? I'm assuming that's why you went through three of them? Also, what type off SSD were you using?


Give this a read! Your Hard Drive Cable Is A Ticking Time Bomb Also keep in mind the OP's question is for a different model! The older 2009 & 2010 can encounter different issues! often times people put in too fast a drive for the slower SATA II interface these older systems have. Review your drives spec sheet it needs to state clearly it supports SATA II I/O data rate as an example [|Samsung 860 EVO SSD) Vs [| Western Digital Blue SSD which is a fixed SATA III (6.0 Gb/s) drive and won't work properly in the older SATA II (3.0 Gb/s) system's!


I was going CRAZY!! Everything was lagging.. every two clicks the spinning wheel.. Tried all the software stuff (resets, formats, reboot, reinstall)... was about to give up then I read this comment! Thank you @davehartley !!

I took my Mac Mini 2012 apart, and the Hard Drive Cable (or better, SSD drive cable) was full of dust between the pins.. took a needle to clean all the dust in between, gave it some good blows, put it all back together, and SWOOOSH, my 2012 Mini is back to its amazing speed, 9 years in.. WONDERFUL!!!


Add a comment

the hard drive name has nothing to do with it. You can name it whatever you want as long as you select it in the system preferences control panel as the startup disk.

Was this answer helpful?

Score 1
Add a comment

How do you set it to the new SSD? It still only has the Mac HD listed.

Was this answer helpful?

Score 0


Press the Option key when you start you system. You'll be greeted with the Disk Manager which will allow you to select the boot disk. Once you system is up and running go over to your System Preferences, there you'll find the Startup Disk control panel, open it and select the drive and you're done. If you can't see the disk its not prepped correctly and/or is missing the OS. You'll need to redo the drive setup and re-install the OS from the installer app.


It's also worth noting that if you clone the old hard disk onto the SSD, you'll retain the name "Macintosh HD" for the SSD. This is not sufficient to automatically boot from the SSD. (Somebody correct me if I'm wrong, but the boot loader works with physical disk IDs, and not the name, since it has to boot before the file system is loaded.) You'll need to set the boot disk to "Macintosh HD" once again to register the new disk.


Good point! @EBarnhart001 Another reason not to use cloning software as it just confuses things.

I know old habits are hard to shake, cloning is one of them! I have had more problems with cloning software than I can shake a stick at. Apples Migration Assistant or TimeMachine backup is the only real way to do it.


I don't remember if I cloned or restored the system disk image from a backup onto the SSD. Probably the latter since I used no special software. Anything that saves the hassle of reinstalling the system is a good idea IMO. The user just needs to unset and reset the startup disk setting, even if it looks correct in the control panel.


@EBarnhart001 not true. It doesn't have to be called Macintosh HD at all. That's simply the name Apple gives it by default. I rename all my HD and SSD to MacOS HD and it won't affect a thing. All apps will see it etc. The name can literally be anything. He'll you could name it floppy disk for all the Mac is cares. Just be sure it's set to the default startup disk in system prefs and it'll boot fine. This issue 8s definitely the sata cable. even after a successful clone you can go in and rename the same hard drive you just clone to whatever you want and the system will still boot just fine. It's all about the Sabbath bus and has nothing to do with the actual name that you give the drive. try it out, rename your hard drive and reboot your machine and it'll boot up just as fast and everything will retain its symbolic links etc you won't have a single issue


Show 1 more comment

Add a comment

Here is what worked for me. I did a SuperDuper clone from a 256GB Samsung EVO 840 SSD to a 1TB Samsung 860EVO. After doing this the MacBook booted up ok but I noticed that there was a click delay on every action and everything seems to have somehow slowed down. Almost like the hardware know that the SSD has been removed and was trying to verify every file that was being opened.

BlackMagic disk speeds didn’t reveal anything out of the ordinary. I tried to update the Samsung SSD firmware and it was already updated. I ran disk utility and did first aid. None of these solved my problem.

Finally, I booted the mac into recovery (cmr+r) and did an OS reinstall. This fixed my problem. You don’t loose any of your files or applications. It simply does a reinstall.

Hope this helps.

Was this answer helpful?

Score 0
Add a comment

Add your answer

briandholley will be eternally grateful.
View Statistics:

Past 24 Hours: 23

Past 7 Days: 105

Past 30 Days: 497

All Time: 76,501