MacBook Pro 15" Unibody Early 2011

Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

257 Questions View all

Not powering up, Green LED on Magsafe adapter, Battery indicator blink


I have 2.0Ghz A1286 MBP 15" and it is not powering up. I tried several MagSafe Adapters and it just lit up to GREEN and I tried to press the battery level indicator and all leds just blink. Is my magsafe board toast? or the whole logic board? Hope I can get an answer before I replace the wrong part.

Thank you!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Maybe try leaving it plugged in for a while, if the battery is completely discharged, then it will need to charge for a bit to be able to boot up. When you press the power button, does the sleep light in the front blink in any pattern, or can you hear fan noise/HDD noise coming from inside? This may help further diagnose the problem that is occurring, because it could be several things with the description that you gave us.

Hope this Helps

- Owen

Was this answer helpful?

Score 0


i tried but the LED on the charger stayed GREEN. No noise from fan or HDD.

by carlks

Add a comment

Add your answer

carlks will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 300