Not enough disk space? Need a backup solution? External drives provide you with extra storage in your office or on the go. Learn how to repair them here.

153 Questions View all

Why can't I add files to my Toshiba external hard drive?

I plug in my 1.5 TB Toshiba external hard drive on a Mac, and I can view my files and copy & paste them to my desktop. But I cannot add any files to the hard drive. A "cancellation" sign appears when I try to drag and drop any type of file. I have over 1 TB of files on the drive with 500 GB of free space left. I would transfer files to another device then attempt reformatting it, but I don't have the time or money to do this. Any help or suggestions? Thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 3

Comments:

You can buy Tuxera NTFS and download onto your Mac. there is a 14 day trial free period and then you can buy it for £15. Then can instantly download on to hard rive from Mac. Much easier than doing it yourself.

by

Add a comment

8 Answers

Chosen Solution

You could try burning a few DVDs with the data to back it up first if you can't get another HD to hold the files even temporarily.

As for fixing the problem, first make sure you have a backup as you might lose a few files in the process. Try running Apples' Disk Utility program first verifying the disk and then repair it if needed. Then try fixing the permissions again—first verifying then repairing it.

If you still have problems you may want to try a 3rd party app like Disk Genius It also can defragment the drive as well.

The last option is to reformat as you already know. Good Luck.

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

If your Toshiba hard drive does not give you the paste option, just follow the steps:

1. Save any file in your hard drive Toshiba in any source

2. Open Finder

3. Go to applications

4. open Utility folder

5. Go to Disk Utility

6. Select on the left of your window your Toshiba Hard drive

7. Select format: Mas OS ( journaled)

8. Click on Erase.

And that's over. You can then paste what ever you on your hard drive. The name of your hard drive will, obviously change to Untitled. You can later rename, if you want.

Was this answer helpful?

Score 11

Comments:

thanks - simple and successful. what is the problem with this hard drive anyway that this is a common problem

by

Perfect. It works.

by

Great instructions! Worked like a charm!

by

does this delete all your file that are already on the hard drive?

by

does this delete all the files already on the hard drive??

by

Show 10 more comments

Add a comment

If your ext drive is using Microsoft's NTFS, there's your problem. Back up your files in it, then use Disk Utility to erase and format your drive with the Mac OS Extended Journaled file system. Note that if you use this drive in a Windows machine, you'll have problems with recognition of the new format system.

Was this answer helpful?

Score 0

Comments:

Good point! But I get a different error when I try to copy files to a NTFS volume. If that were the case he can get a NTFS mounter extension to allow his Mac to read & write to the NTFS volume. Its possible he had this and for some reason the extension is no longer working which could explain the odd error. I would still try to fix the disk first under Disk Utility as I had outlined above. It will also show what the drive was formatted with putting his mind at rest.

by

Add a comment

i had the same issue after I got a new laptop. I did not want to reformat my external -- just add more to it and take stuff off it. To add new photos and videos -- i went up to the New Folder section; made and opened a new folder and dragged (drug?) the photos / videos into folders. It worked!

Was this answer helpful?

Score 0
Add a comment

I did something bizarre and it actually worked. My Toshiba drives' permissions changed suddenly while using it. I am a strict mac user and I was trying to copy footage from an sd card. It really needed to be copied and I noticed that the driver had changed to Microsoft's NTFS. I had access to a window's system and computer (Boooooo) lol so I attached the Toshiba drive and SD card to that computer and copied the footage over. After it was done, I reattached my toshiba drive to edit on my mac and to my surprise my permissions had returned. In short i'd say to try connecting your drive to a Windows system then backt o your mac to see if it helps.

Was this answer helpful?

Score 0
Add a comment

I'm working from a very low storage space laptop. I dont have another hard drive to move my external files to (270 GB worth) and then reformat. Is there another solution that doesnt require moving files to and fro?

Was this answer helpful?

Score 0
Add a comment

I am using a mac(Love Apple) all you have too do is erase the usb hard drive from the disk utility manager and then eject it, after that your hard drive should work and you can choose permissions and other things as well!

Was this answer helpful?

Score 0

Comments:

If I do this, will it erase the content that is already on my external hard drive? Also, will the external hard drive then only be compatible with my mac? Thanks

by

Add a comment

Hello everybody!

I have a PROBLEM....

1) I wanted to use this toshiba on my macbook. But could not get it up and running (as is I could not copy files from my macbook to toshiba external hard disk.)

2)Then I found this wonderful solution and I followed every single step (on the first above steps - posted by 'Bel Naddar'). It worked of course..and I can copy my files from Macbook to Toshiba external Drive.

3)Then when I did that, I found out that it deletes all the files on my external hard drive......And now I am very very sad. Because there were two maps on that Toshiba external hard disk with photo's and videos of my children.

4)That is why I need to ask you this question. Is there in any way possible for me to retrieve those previous two maps (with all photo's and videos) back? I have tried 'Wondershare Data Recovery' already, but I am getting nothing back.

5) Please, can someone help me on this?

Thank you so much in advance.

Cindy

Was this answer helpful?

Score 0

Comments:

try icarerecovery program

by

Add a comment

Add your answer

Myk will be eternally grateful.
View Statistics:

Past 24 Hours: 157

Past 7 Days: 963

Past 30 Days: 4,146

All Time: 92,632