White screen after display unit replacement, no apple on screen

Hopefully someone could me out from below situation.

Screen unit is replaced and when turning on only white screen appears. Switches on and off, but only white screen when on. None following:

- Tried to reset by holding power and home buttons long time. Seems to work, but now change on white screen behavior

- Tried to reboot to original setting by holding power and home buttons while connecting to iTunes. Reboot cycle finishes properly, but no change on white screen problem

- Opened again and cleaned connections -> no change

- tried with old cracked display -> no change (even the cracked display worked fine before replaced)

- checked the connections, they seems to be ok

I did not see any damage on volume button flat cables, but they got stress when opened.

What might be the possible cause?

Any help welcome, Thanks in advance, Tinksi

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hello, I encountered this problem a while ago with an older 2nd generation model, to restore the iPod to factory settings ('Original Settings') you need to load up the iPod summary page within iTunes and select 'Restore iPod'. This worked for me and the iPod was back up and running again, If you have anything on the iPod that you wish to keep please back it up first using iTunes also :) It may not work but it's worth a try.

Hope I helped :)

Was this answer helpful?

Score 0
Add a comment

Add your answer

Timo Jauhiainen will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 216