Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

931 Questions View all

Won't charge after battery repair. Any ideas?

Hey everyone, i have a bit of a problem here.

So about a year ago, my HDD kicked the bucket. I have recently managed to get hold of a new hard drive and battery for the thing. I opened up the casing (i don't *think* i damaged the logic board) and replaced the battery and the HDD, but now I can't get it to charge up. When i connect it to the power supply, it says i need to restore the iPod. When i connect it to the computer, nothing happens on the computer and the screen just shows the "please wait, charging" screen.

I've tried using my old battery and that hasn't worked either (but the batter had been dead for over a year...)

No idea what to do here. Anyone able to shed some light on the situation?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Ben, of course it is possible that you have a bad battery. Even a new one can be bad. My main concern with this model iPod is the battery connector. It does have an issue with coming off the board. Double check that connector. Also, make sure that the battery cable is properly seated, another issue on this model. Check your dock connector for any broken, bend or corroded pins, clean it with some isopropyl alcohol and a few puffs of compressed air. Of course, you also want to let it charge on an AC charger for a while. Hope this helps, good luck.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Ben will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 125