Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

232 Questions View all

Where are the diagnostic led's on this model's logic board

Hi allmighty gurus from ifixit!!!

I have a EMC 2389 21.5 inch iMac it doesn't turn on. No chime, no Fans, nothing i opened it and I'm looking for the diagnostic leds to see if the internal power supply its really the culprit.

Can someone please show me light! Thanks for your time in advance! :)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

The LED's are on the logic board to the right of the RAM slots and between the RAM slot and the HDD sata connector

LED #1

Indicates that the trickle voltage from the power supply has been detected by the main logic board. This LED will remain ON whenever the iMac is connected to a working AC power source. The LED will remain on even when the computer has been shut down or put to sleep. The LED will turn off only if the AC power source is disconnected or the power supply is faulty.

LED #2

Indicates that the main logic board has detected proper power from the power supply when the computer is turned on. This LED will be ON when the computer is turned on and the power supply is working correctly.

LED #3

Indicates that the computer and the video card are communicating. This LED will be ON when the computer is communicating properly with the video card. If LEDs 1 and 2 are ON and you heard the startup sound, but LED 3 is OFF, then the video card might be installed incorrectly or need replacement.

LED #4

Indicates that the computer and the LCD display panel are communicating. This LED will be ON when the computer is turned on and video signal is being generated. If the LED is ON and there is no image on the LCD display panel, the LCD display panel or inverter might be installed incorrectly or need replacement.

Pic is from the 19th December 2007

Block Image

Where can I find the diagnostic LEDs on first iMac Intel?

Was this answer helpful?

Score 4

Comments:

Thanks! the pictures appear to be from another model... but anyways y connected and I'm positively sure no less are turning on... you think its the internal power supply?

by

I found them!!! they are just above the mic connector on the logic board. they have 1, 2, 3 ,4 inside a circle and besides each little square led there is a numeration that read "led605" and son on for each one. None of them are turning on. You think its the internal power supply???

by

Sorry for the wrong pic.

by

I would start with the power cord, try a different one (a non-apple standard three prong cord will work).

Then after opening the system check with a Ohm meter, check continuity from the power socket in the case to the power supply to make sure the PSU is getting AC. And double check the DC side cable connections.

If that all checks out the PSU is bad.

by

Thanks!! Dan ! I already did the cable thing i tried 2 different cables.. I will test the continuity to see if the psu is bad.. Again very helpful.. Thank you!

by

Show 4 more comments

Add a comment

Add your answer

eduardo will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 324

All Time: 11,363