My DVI output is all red!

My macbook is approx 2.5 years old now and I have had no issues what so ever with it, except one day, I plugged my 2nd display into my DVI out and even though the screens were shared correctly, my 2nd display was pretty much totally coloured in red! i have tried plugging into LCD TVs over DVI-HDMI but the same happens. Perhaps a pin is damaged in the DVI connection port causing blue or green to stop coming through?, or could it be something more serious? Any ideas on what I can try? Is is possible to replace the DVI port rather than replacing the entire motherboard? Thanks in advance!

Answer this question I have this problem too

Is this a good question?

Score 3

Comments:

I had the same problem. I checked the port with something similar a plastic fishing line and now it doesn't work anymore. I guess the contacts are not working inside the port.

If there is no a way to change the port, how could I check the conductor inside them?

Thanks.

by

Add a comment

2 Answers

Most Helpful Answer

I've had issues similar to this where the cable had gone bad. So I'd suggest trying different cables. This can also happen if the cable is for some reason not sitting properly in the socket.

Was this answer helpful?

Score 2
Add a comment

look in your connectors and make sure nothing is jammed in there like dirt or something to prevent a connection. A bad connection from the connector on the device will not be fixed with a new cable.

as for replacing the port, it would be very difficult to just change it out. maybe you can see what hole has an issue by looking for a lack of conductor inside them.

DVI runs in a few different modes with different pinouts, it sounds like your on a DVI-A for an analog signal but I havent see what the DVI-D signals do with limited pins connected.

Was this answer helpful?

Score 1
Add a comment

Add your answer

stevobourke will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 3,031