Eighth generation of the Mazda Protege.

44 Questions View all

Bad idle, Rpm unstable

What cause this problem ? Idle move from 600 rpm to 1100 and drop to 400 and back to 1000 non stop. ?

All explain are approximative value.

The model is Mazda protege 2002, 2.0 Lit

The ODB read a alarm code miss fire.

Some people think that could be a timing belt problem

The mileage is around 109 k km

Thank you in advance

Yvon K

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Yvon, does your OBD give you a numbered error code? It is possible that it is your timing belt, but it is also possible that it is your coil, cable, cam shaft or crank shaft position sensor, EGR valve and Idle air control valve, as well as many more items. The error code could help us diagnose it a bit better.

by

Add a comment
Deck the Halls
With tools and Fix Kits

6 Answers

Most Helpful Answer

Most commonly this would be the EGR Valve.

Was this answer helpful?

Score 1

Comments:

Mazda Protégé's are notorious for dirty or bad egr valves.

by

Add a comment

I had drops of RMPs and stalls at idle (e.g. at a stoplight) and a O2 trouble code on OBD. I found a crack in the air hose between the air cleaner filter box and the throttle plate. Replaced it myself and fixed the problem.

Was this answer helpful?

Score 1
Add a comment

It could be your MASS air sensor. If you damaged the MAF, you destroy an electrical circuit, which can make it difficult to start, if not impossible. If you manage to start it, then drive it for a while, then stop, then it will start rpm fluctuations.

Was this answer helpful?

Score 0
Add a comment

Check your spark plugs for oil leaking into the spark plug port. I noticed my protege acting erratically and had a misfire code so I replaced my plugs and all was well. There's a gasket ring that surrounds the spark plug port in between the head and the valve cove that gets worn out. Check your entire valve cover gasket, or seal, and see if that might be the issue. Also check your oil to see if its been dropping and add accordingly.

Was this answer helpful?

Score 0
Add a comment

I found it was the intake manifold gasket, siliconed it up runs like new now, apparently its a common problem says the Mazda spear parts guy

Was this answer helpful?

Score 0
Add a comment

I tried resetting the engine control computer (yes, there is a computer on-board). I did it by disconnecting the battery, tap on the brake (this will drain all the electrical potential from the car), and reconnecting the battery terminals. Note that you may want to gather up all your manuals for your stereo, and remote starters before you disconnect the battery, because they will all get reset to factory state during the process mentioned above, and you will need to retune the clock, radio presets, and pair the car starter to your remote controller.

Was this answer helpful?

Score 0

Comments:

I am having rpm trouble going from 400 to 1100ish but no check engine light and my headlights flash really bright then dim. Any thoughts? Thanks

by

Add a comment

Add your answer

Yvon will be eternally grateful.
View Statistics:

Past 24 Hours: 23

Past 7 Days: 119

Past 30 Days: 557

All Time: 10,762