Power button isn't working after repair

I recently asked a question about repairing my iPod, because the home button wasn't working, and somebody gave me an answer with a guide on how to do it. I followed the instructions,and decided that before permanently putting it back together, I would put it together without the adhesive strips to make sure everything was working properly. The first couple of times, it came up with a white screen, but then it turned on, and worked fine. We went to put the adhesive strips on, and the cable on the top had come unclipped. We have tried snapping it back into place multiple times, but even when it appears to be in place, the iPod won't turn on. If anybody knows what might be the problem, I would greatly appreciate some help. Thank you.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

May be the power btn cable is damaged

iPod Touch (4th Gen) Volume/Power Cable

Was this answer helpful?

Score 0
Add a comment

Add your answer

Rick will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 818