iPod 5th Generation (Video)

Model A1136 / 30, 60, or 80 GB hard drive / black or white plastic front

693 Questions View all

Replaced the hold switch and now click wheel is not working.

I have pulled apart my 30GB iPod video again to make sure I didn't miss anything. I have also done a restore with Itunes. The reset function works fine (holding the menu and center button until reboot). Toggling the hold switch on and off works fine as well. No response at all on any of the buttons other than the reset function. Please help!

Answer this question I have this problem too

Is this a good question?

Score 4
Add a comment

4 Answers

Most Helpful Answer

Retake it apart. Buttons may be stuck.

Was this answer helpful?

Score 2
Add a comment

The click wheel has to align in a specific way...if im not mistaken 3 little holes on the bottom of the click wheel button should help you align with ribbon cable...do you hear click sounds when pressing the button?...if not then its not align properly

Was this answer helpful?

Score 2
Add a comment

Check and recheck all ribbon cable connections, this is most likely where the problem is. Sometimes they appear all the way in but are not quite making contact.

Was this answer helpful?

Score 1
Add a comment

When openning you broke your click wheel cable or you dont have it grounded because the tail ribbon of the clickwheel came of the frame of the iPod so know you iPod will not work

I hope this helps

Was this answer helpful?

Score 0
Add a comment

Add your answer

gary will be eternally grateful.

View Statistics:

Past 24 Hours: 1

Past 7 Days: 5

Past 30 Days: 10

All Time: 6,289