H2O Mop X5 - It makes no more vapor.

Hello,

I bought the " H2O Mop X5 " from the teleshopping "EUROSHOPPING" a few months ago. I used it only about ten times.

It put more and more time to make of the vapor. Now it makes it no more. I tried to decalcify it but that changes nothing.

Thank you for helping me to find a solution!

EUROSHOPPING - H2O MOP X5

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Is it still covered under warranty? If so, I would definitely return it. Let us know so we can try and work on a solution.

by

It is still under guarantee.

I read again the note of the device (very long), it is noted that in certain regions where the water is too calcareous, it's better to use some demineralized water.

Having decalcified it second time, it began re-working (after a while).

I think that the vien problem from there.

I am going to buy some demineralized water and test it with.

Maybe that it will raise no more problems.

by

That sounds good and let us know if that worked. You also might try to descale the mop.

by

Hi I have the same problem. It is probably because limescale has blocked the boiler. If you are still under guarantee definitely send it back. Demineralized water won't work if the boiler or tubing is blocked with limescale. First try a solution of Vinegar and water (Vinegar dissolves limescale) if that doesn't work see https://www.youtube.com/watch?v=JGLtb7UV... which shows a teardown and repair.

by

Add a comment