Skip to main content

Model A1013, A1052, A1085, or A1107 / 1440x900 screen resolution

121 Questions View all

OS won't install on a PowerBook G4 aluminum

'This is a long winded post but as detailed as I can get:

Have a Powerbook G4 17" with 2G RAM, 80G hard drive, 1.67GHz... my son deleted the system folder and now the machine will not boot up. It was running 10.4 everything worked prior to OS being deleted.

So I tried an original Powerbook G4 install disk* at start up holding down the C key but the disk was ejected. Then the folder with question mark and flashing mac icon showed up. *(PowerBook G4 15-inch and 17-inch Software Install and Restore. Mac OS Version 10.3, AHT Version 2.0.6, DVD Version 1.0, 691-4703-A)

Then I tried same as above with original PowerBook G4 install disks for a 15 inch*. These install disks come as a pair disk 1 and disk 2. The second disk includes Mac OS 9.2. but I never got to install since the first disk was ejected like the one above. *(Install disk 1 Mac OS version 10.4, AHT Version 2.5, Disk Version 1.1, 2Z691-5517-A, 2005)

Then I Firewired the 17" into my 15" making the 17" the target disk and reformatted/erased the 17" drive using Disk Utilities from the 15". Tried again to install as detailed above but got the same results... Start machine, holding down C, insert disk, hear the drive engage, then eject and the folder with flashing ? and icon appears.

Then I bought an original retail, full install version of Leopord 10.5, Install DVD, 2Z691-6038-A, 2007 and tried to install that but got the same results as above.

So I tried copying over from the 15" to the 17" system and library then restarting the 17" but of course that didn't work. I then reformatted and erased the 17" and have retried all the above PLUS holding the Option key down on the 17" while starting up.

While holding the Option key at start up the screen came up with the stop watch which circled for about 20 seconds before the pointer and two option buttons appeared, one button to go forward and one to re-circle what I presume is the previous operation. I tried to click the forward button but the pointer disappeared. So I restarted again, same scenario only this time the pointer held and I clicked the forward arrow. Nothing happened. I clicked it again, nothing. I tried clicking the circular arrow and nothing there either...

I am out of ideas. The CD hardware was working fine prior the OS being deleted. And it sounds like it reads the disks then spits them out. Disk Utilities hasn't given me a hardware problem in regards to a faulty CD player but then I don't know if I have tested for the specifically. The Hard Drive has been successfully reformatted a couple of times now... why won't an OS load on this 17"???

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

Sorry your having such a hard time here.

As you know the PowerBook G4 is the last laptop Apple made with the PowerPC CPU chip Wikipedia Info. As such your OS choices are limited and Apple no longer offers help or services this system.

As you have a real copy of Leopard DVD (10.5) you should be able to recover things. As long as the system is functional.

If you can mount the system in disk mode to the other Mac system you should be able to install a full copy of OS manually.

You're right the system you have running will ID the software installer (15") incorrectly (the one in disk mode 17"). To correct for that you need to manually install the OS and install the all of the system libraries. When you get to the installer main screen don't let it install the OS automatically, go into the manual area and expand the sub sections and check off the setting that offers the universal boot option.

Don't forget to bless the HD as bootable under the control panel. If you install things correctly you should be able to reboot your master system (the one doing the work here) and the slave system (disk mode system) should boot your master system. If it does you should then be able to shutdown both and disconnect your systems and restart them, both should then boot up off their own internal HD's.

If this still fails you'll need to setup an external Firewire HD with a bootable universal system and then use it to boot your PowerBook G4 from. Again, go into the control panel and make sure the internal CD/DVD player is the bootable. Then use the installer DVD and try again or copy the external HD system over.

Was this answer helpful?

Score 1
Add a comment

Add your answer

ncnet will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 5,233