Student-Contributed Wiki

Student-Contributed Wiki

An awesome student from our education program made this wiki. It is not managed by iFixit staff.

Unit does not turn on ¶ 

The XQ-673H does not work after turning the swith to ON.

Check Power Cord ¶ 

Check if the power cord is correctly plugged into a power outlet. If it is unplugged, plug the power cord into a outlet near the device and make sure the device is in the upright position.

Power Outage ¶ 

Check if all of the other appliances in the area have power. If none are working, there may be a power outage in the local area. Contact the electric company for verification.

Power Switch does not work ¶ 

Check if the power switch is turned on. If problem continues, consult the XQ-673H Power Switch Replacement.

Damaged Power Cord ¶ 

Make sure that there are no cuts or damaged wire strands throughout the power cord. If the power cord is damaged, consult the XQ-673H Power Cord Replacement.

Water appearing around the bottom of the device ¶ 

Water is leaking through the bottom of the unit and around the surrounding area.

Excess Water in Reservoir ¶ 

Too much water has been poured into the water tank and may be overflowing. Watch water window while pouring in water to ensure the water line is always visable. This will prevent the water from overflowing from the reservoir.

Damaged Water Tubes ¶ 

The water tubes inside the device is damaged and is allowing water to escape from the inside. The water tubes may need to be replaced. Consult the XQ-673H Water Tubes Replacement.

One Comment

The water tubes are different, one has a small check ball valve. Which side does that tube go on?

Thanks for your assistance,

Texas Ed

Edward Blatz - Reply

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 78