Unit does not turn on ¶ 

The XQ-673H is nonfunctional after setting the switch to ON.

Check Power Cord ¶ 

Check if the power cord is properly plugged into the power outlet. If it is unplugged, plug the power cord into a nearby power outlet and make sure the unit is in the correct position.

Power Outage ¶ 

Check if other appliances in the area are functional. If none are working, you may have a power outage in your local area. Contact electric company for verification.

Damaged Power Cord ¶ 

Make sure there are no tears, cuts or damaged wire strands throughout the power cord. If the power cord is damaged consult the replacement guide.

Switch is broken ¶ 

Make sure the switch is in the on position. If the switch is still not working, consult the replacement guide.

Water appearing around the bottom of the unit. ¶ 

Water is leaking from the unit and onto the immediate area.

Excess water in the unit ¶ 

Too much water has been poured into the unit and may be overflowing. Monitor the water filling station and make sure the water line is visable and not to pour over the stated amount. This will prevent water from overflowing from the unit.

Damaged Water Tubes ¶ 

The water tubes inside the unit and is allowing water to escape from the inside. Slow brewing may occur or stop completely from this issue. To fix this issue, the internal water tubes must be replaced, consult the internal water tube replacement guide.

0 Comments

Add Comment

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 22