« Back to All Stories

2011 iMac sob story.

by bcageprotection

My Problem

Came downstairs one day to find my computer off. Strange comsidering I always leave it on. Pressung the power button yeilded nothing. No fans, beeps or anything to suggest power. I got on the web and found this site. After reading many comments I came to the conclusion I may have a faulty power supply.

My Fix

I ordered the part and it arrived quickly. I used the guide on the site to replace the old power supply only to find out it was not the trouble maker. While my mac was opened I checked my LED status lights (something I would reccomend doing first next time) to discover I was getting 1 LED while plugged in but, pressing the power button made no progress nor did it light any other LEDs. After posting a question about my dilemma I was quickly answered by one of the fine people on this site. Our agreed opinions matched that I must have a bad logic board. Booooooo. I have a feeling it may have been caused by using a third party usb hub something I have now found to be a major problem with iMacs. If only I had known! Although my story ended badly I still will continue to use ifixit for all my needs because they did a fantastic job of helping me every step of the way. Thanks for trying guys! Wish me luck on finding the cheapest solution to my logic board issues and thanks again for the recommendation of ebay logic board repair businesses!

My Advice

Always buy extended warranties for anything that costs a crap ton of money!