Skip to main content
« Back to All Stories

iMac (27-inch, Mid 2011) AMD Radeon HD 6970M 1GB card revived... by baking!

Sebastian -

iMac Intel 27" EMC 2429

Story image
  • Image #1
  • Image #2
  • Image #3

Installing iMac Intel 27" EMC 2429 Dual Drive Kit (HDD or SSD)

1 hour

Moderate

My Problem

My iMac first started showing symptoms by rebooting intermittently. A few days later, the infamous thick bars would appear on the display, at which point the iMac would reboot. The computer would boot back to the desktop and would be usable for a very short period of time before repeating the cycle.

A replacement graphics card for this model (directly from Apple) will run you about $400, plus labor. For that price, you’re better off getting a re-balled 2GB version of the card on eBay for about $300. I work as a repair tech, so I’m used to digging through the innards of Apple machines. I had heard/read of people bringing their graphics cards back to life by simply baking them before I began this whole repair. Considering the price for a replacement/repair, I figured what the !&&*, in the oven you go!

My Fix

I preheated the oven and baked the graphics card for about 10-12 minutes @ ~380-390°F (about 200°C). I then let the card cool down for about 30 minutes. In the meantime, I thoroughly cleaned the graphics card heat sink using alcohol pads and also took the time to clean out the rest of iMac. Once the card cooled down, I cleaned the GPU chip and memory modules again (they were cleaned before the card went in the oven) and reapplied the thermal paste/pads. I used Arctic Silver 5- people might say it’s overrated, but it’s always given me the lowest temps on all of my builds. Once all the new thermal material was applied, I reinstalled the graphics card heatsink & reassembled the rest of the machine.

I plugged the iMac in and powered it on. As soon as I heard the chime and the display turned on (joy!), I reset the PRAM/NVRAM. The iMac power-cycled and then booted successfully to the desktop. So far so good. I let the computer run for a minute or two, rebooted, and ran diagnostics- every component passed except for the HDD temperature sensor. I was already aware of this, as I had upgraded to a 3TB HDD which did not include the port for the temp. cable (this is the case with the majority of non-Apple branded HDDs). This issue can be solved by using fan control/monitoring software, such as HDD/SSD Fan Control. Otherwise, I highly recommend OWC’s In-line Digital Thermal Sensor, which easily attaches to the HDDs current power cable. You can then peel the adhesive on the included thermal sensor and place it directly on the HDD. Regardless of whether you choose the software or hardware fix, they both remedy the sensor issue- or rather, the fan issue (HDD fan spinning at over 4000rpm).

My Advice

Post-repair, my average GPU Die temperature is posting at about 45°C during normal use. I ran Unigine Valley Benchmark using all of the “basic” presets, with the exception of selecting 1920×1080 instead of 1280×720 as the resolution. I ran the GPU stress test under these conditions for about 15 minutes. The GPU Die temp slowly began to rise, peaking at around 90°C (I later ran an extended test for about 8 hours and the log indicates that the temperature never exceeded 93°C). Comparing those numbers to my pre-repair temperatures: ~60°C during normal use, 100-105°C during heavy use, I’d say the new thermal compound is working its magic! Although 90°C is on the higher side when it comes to graphics card temperatures, these cards can safely operate up to 100°C under heavy load. I should also mention that the iMac did not crash at any point during the GPU stress testing.

Judging by the overall temps of the machine, I can definitely see that the repair helped. I’m pretty happy with these temperatures- running the GPU stress test is probably the most… stress… the iMac will experience. The computer is primarily used for day-to-day tasks (email, web, etc.) as well as photo editing using Adobe Photoshop & Lightroom, with some occasional video editing/encoding. I don’t expect to see the GPU temp go above 80°C. If I ever feel uneasy about the GPU temp, I can always get the fans to kick in using iStat Menus (or any other fan control software).

The iMac has been powered on for exactly 1 week now with no issues! I just installed a Samsung 850 Pro SSD underneath the ODD, while keeping the 3TB HDD in the main bay for storage. Speed-wise, the iMac is giving some of the new models a good run for their money!

iMac Intel 27" (Mid 2011) Dual Hard Drive Kit Image
iMac Intel 27" (Mid 2011) Dual Hard Drive Kit

$27.99

« Back to All Stories

41 Comments

Hi Nice job! I am planning of baking my gpu this weekend but I dont have those "thermal pads" do you know if they are required? or can I just use artic silver on the memory chips?

Markus - Reply

Sorry for the delay- just saw your comment. I think the thermal pads are the way to go- if you try using paste on the memory chips, there *most likely* will be a gap between the heatsink and the surface of the chips. You should be able to find thermal pads in bulk on eBay, or elsewhere online. Be sure to get ones that are as thick as the ones currently being used.

Sebastian - Reply

Hey great job! I had just ordered a used gpu off eBay but now I'm going to try baking my old one. It got to the point where the computer would even boot all the way. About the SSD upgrade. Since you have installed the SSD have you noticed your gpu temps higher on average? I'm just wondering about this since the SSD is going under the cd drive. It seems like it would block the path of airflow from the fan below to the heartsink for the gpu? Thanks!

Shute - Reply

I was just about to order the new card today when I saw this. I figured, why not try it? Worked like a charm!! Great write up!! Thanks Sebastian!!

Darrell - Reply

Just wanted to add this:

I had fan issues and tried resetting the SMC and PRAM several times. I took the thing apart half a dozen times to make sure I had everything plugged in correctly. I measured each sensor (disconnected) and got roughly 5.2 MOhms on each one. This eliminated bad cables or sensors like all the other forums say.

Basically, the connectors are not the best. I disassembled the iMac completely again, and removed the logic board. I reinstalled it and slowly connected everything back up. On the sensor wires, I used the spudger to push the pins further into the connector, after they were connected. Buttoned it all up and without needing to reset anything, all of the fans were running nice and quiet. Everything is looking good. Hopefully the baking experiment will keep the video card going for a while.

Darrell -

Add Comment