Skip to main content

Fix Your Stuff

Right to Repair

Store

Help

Step Type:

Drag to rearrange

All warnings from Part 1 still apply.

Look at what OS version your calculator is running. It will be under the calculator's name in TI-Connect CE.

If your calculator is running OS 5.3.0 or lower then download OS 5.3.0: TI-84 Plus CE | TI-83 Premium CE. If you're running between OS 5.3.1 and OS 5.4.0 then download OS 5.4.0: TI-84 Plus CE | TI-83 Premium CE. If you're running OS 5.5.1 or higher then download the latest OS from TI's website. WARNING: OS 5.5.1 and higher disable the ability to run most games and some programs! Once you update you cannot downgrade!

If you do not know what OS your calculator is running, try each OS in ascending order. Remember, the latest OS will disable the ability to run most games and some programs! Once you update you cannot downgrade! OS 5.3.0 and OS 5.4.0 are perfectly safe to update to. Anything higher is not.

In TI Connect CE, click on 'Actions', then 'send OS/Bundle to calculators...'

Navigate to where you saved the OS and select it.

Wait for it to load, then click 'send'.

This will take a few minutes.

Your contributions are licensed under the open source Creative Commons license.