Skip to main content


After a few weeks of use, some keys of my Zenbook keyboard became unresponsive. In my case, it was the vertical key rows. After opening my laptop I noticed the cable was unlocked. This guide will show you how to reconnect it.

This fix may not work in every scenario and is not guaranteed to work. This is a noninvasive fix you can try before sending the laptop out for repair or buying a new palmrest assembly.


No parts specified.

  1. Unresponsive keyboard fix, Remove the bottom cover: step 1, image 1 of 1
    • Note: These 2 screws are longer then the others.

    • Unscrew the remaining 8 screws. These are all the same length.

    What is the size of those screws?

    Mill - Reply

    T5, the shorter screws from an email with a representative are: D2.5*2

    thefinalzeta -

    What a relief. One day my Zenbook laptop was working just fine. Next day I had no 'd', 'del', 'delete' or back arrow, and I was going crazy, since this would be like the 5th laptop in a row I've purchased that has gone bonkers on me within a year. Wasted a lot of time trying to reinstall keyboard drivers etc. all to no avail. Then found this page, and 10 minutes after getting a T5 Torx driver the it's fixed and working perfectly.

    Thank you so much for taking the time to detail and post this.

    Justin LE - Reply

    thank you! I couldn't believe this. I had the same problem. It began with unresponsive "a", after all half of the buttoms were dead. Hope this is an permanent solution...

    It's a shame Asus still sells this stuff ... They told us it could be a software problem ...

    verswe - Reply

    Thank you SO much! I was stumped until I saw this very good write up. If you ever make it to Rochester MN I owe you a beer.

    Martin Keech - Reply

    Francis, Thanks so much for posting this! My Zenbook is 3 months old and suddenly stopped powering on, nothing. I took it in this morning and they said it would be 15-20 days before they could get to it. I took out the battery tonight thinking that was the problem. put it back together and did one last search before taking it in tomorrow.

    This saved me.

    My 84 year old father was watching in awe as I did the repair following your guide.

    Can't thank you enough. Your details are amazing.

    Orest - Reply

    Thanks so much for posting this!

    My 1 year old UX31 keyboard slowly lost responsiveness to more and more keys ( Enter, L, and others. )

    When I applied pressure to the notebook frame with one finger right above the f10-f11 key, all the keys worked, when the pressure was off they stopped working, so definitely a connection probelm.

    After reading your great post, I fixed it by pressing in the keyboard connector locks all the way in.

    G I - Reply

    Thank you this worked great and was exactly the problem when my E and R key stopped working today on my Zenbook.

    Darren Thurston - Reply

    My power key stopped working. Instead of sending my laptop back to Asus, I followed these instructions lucky to have the hex tool (ordered from ebay for another problem) and had it fixed in 5 minutes. This has made my day. Shame on Asus for this obviously common problem, thank god someone was kind enough to make these instructions. What a legend!!

    rob Surf - Reply

    Does anyone know what length the short T5 Torx screws are and where I can order them?

    Thanks so much in advance!

    Jtarta1 - Reply

    From an ASUS rep: D2.5*2 (short screws)

    All I have been able to find is this website but I don't think it's cheap for the U.S.

    thefinalzeta -

  2. Unresponsive keyboard fix, Remove the battery: step 2, image 1 of 1
    • Remove the back cover. There are no warranty stickers that need to be broken.

    • Locate the keyboard connector. It is covered with a piece of tape helping hold it in place. This tape often fails after a certain amount of time.

    • You may need to remove the battery to disconnect it. Unscrew the 3 screws holding the battery in the system.

  3. Unresponsive keyboard fix, Reconnect the keyboard: step 3, image 1 of 1
    • Remove the tape covering the connector. Note: New tape should be added once reseated.

    • Here on the picture you can see the connector in the unlocked position. These hold the connector in and should be completely pushed in.

    • Push the connector in. Do this until it is secure.

    • Lock the tabs that retain the keyboard connector in place.


Screw everything back and if you've done it right, enjoy all your keyboard keys again.

95 other people completed this guide.


Member since: 11/29/2012

1,777 Reputation

1 Guide authored


Awesome fix, thanks! This exact issue was plaguing the up and down keys on my UX31 (this is after having to RMA the thing for power issues). Be forewarned, if you are attempting this on a machine that is in sleep or hibernation mode, it has the potential to shut it off, with no visible LED lights to indicate. You can reset by holding down the power button for ~10 seconds and it should boot back up, if not, check connections again.

The LED light on the charging cable is a decent indication if something's up or not.

Jeff L - Reply

Yep, this worked on my zenbook UX31A. The two white push tabs have to be fully in for the wires in the ribbon cable to contact. When u push in one, the other one pops open, so push both together.

Also, MY zenbook needed a torx T4 to unscrew the screws.

spud -

Great fix! My shift keys were not registering, and upon removing the back I saw the keyboard connector was indeed loose. Securing it in place fixed the problem. Thanks a lot!

Adolfo Brandes - Reply

Thanks for this! I had random keys unresponsive at various times, my white connector was plugged in on one side but not the other. See-sawed it back and forth until they were both in.

I think the cause is the battery; it physically places the keyboard cable under stress. I replaced the tape with much stronger stuff but am not sure if it will be a permanent fix...

Jonathan - Reply

Thanks man, you are the best!! This is a great notebook, and this problem was starting to make me hate it. Easy as cake. Wish you good fortune and the best of luck.

Saturnin Kepa - Reply

Well written, easy to follow and great pics. Allowed me to get my UX31A back up and running on the same day the connector dislodged. Really appreciate your efforts in creating this fix and sharing. Thank you!

Paul - Reply

Worked for me too. I was astonished when I inspected the two white holders (circled in red in the photo). They were visibly dislodged, barely inserted. I'm a little surprised the keyboard was working at all.


When applying the gentle pressure needed for the fix, note that pushing in the holder on one side serves to push the one on the other side OUT. You must push in both at the same time. I used jeweler's screwdrivers for the work, and a magnifying glass; these parts are rather small.


Once the holders were both pushed in, the keyboard began to work correctly again. Excellent! But work for how long? The piece of paper tape laid across the connector and the two holders -- seen in photo #2 -- is beyond pathetic. Here we have a one-thousand-dollar device full of precision electronics, and its correct functioning depends on a scrap of ADHESIVE PAPER TAPE? It's the lamest thing I've ever seen. ASUS should be ashamed and embarrassed.


Many thanks for Francis for the solution and clear instructions.

Tom Davey - Reply

Very easy fix with no special knowledge required--just a precision screwdriver kit.

Stephanie - Reply

THANK YOU SO MUCH FOR SHARING THIS FIX. I did it and it worked great. My Zenbook started with the arrow keys and then moved to the backspace and delete keys. Yesterday the Power key was dead. So I decided to do it and "voilà", it is working perfectly again.

I want to share with you that I wrote several times to ASUS Support and they never replied, except for a questionaire they sent asking me to grade their support, which I never received. It is a pity that such big companies just ignore costumers asking for support when having trouble with almost brand new expensive computers. I believe this same problem is a recurrent one since you can find many posts on the internet regarding the same issue.

Once again: Francis, thank you very much for the fix; very easy, very clear and very helpful.

Edgardo from Colombia

Edgardo - Reply

thanks for your help, i used some 3M reflective tape to more securely adhere the connectors, just one note--usually when you press on one side of the connection the other comes loose so be sure to press both at the same time before re-taping...thanks again.

adam - Reply

Beautiful -- worked for me as well. I had lost my "4", "w" and right arrow. Now I am back to writing words with w's!!

Bill Herring - Reply


Simple fix for a major headache.

I opened up the laptop and took off the yellow tape, and stared at it for a sec saying "what now?"

Took a closer look and you had to push the pins up (they are about halfway down), so did that, put some tape, voila!

Ben Wu - Reply

This was annoying me to no end... I just did it and it worked. One of the push tabs was open but the flex was still sitting properly inside.

Those push tabs do exert pressure on the flex contacts so even if the flex is inserted properly thing may not work.

Patrice Laroche - Reply

THANK YOU Francis! Took me less than 5 minutes and I had never opened up a computer before. Happily I am no longer slamming on my keys in frustration. I used two small jeweler's forceps to squeeze each side of the connectors together.

For others researching this, my problem started with the up/down arrows and progressed to sporadic problems with various letters. ASUS support tried to blame it on the OS... of course.

creaturedoc - Reply

Thanks very much. This worked perfectly for me. I was just about t box it up and return it to the retailer. I used 'Gaffer Tape' (cloth based tape) to retain the connector. The original tape did not seem to be man enough for the job.

Robin - Reply

Thanks very much as well! I actually have the UX32A and I had the same issue as well! (Just goes to show that this change wasn't captured in the model change). The only difference is that there is actually a pretty sturdy piece of tape (hockey stick tape?) already in place, holding down the keyboard controller ribbon to the top of an adjacent chip. The main issue being that despite this tape the keyboard controller still comes loose. Not sure if there is a recommendation for a good permanent fix to this? Any thoughts on using crazy glue? Are you guys actually taping around the clips, or just the ribbon/???

Iwan - Reply

I'll add my thanks to the list. I also have a ASUS UX31A. One difference is that when I removed the back cover is that I found there was no tape on the keyboard connector at all. There was masking tape on the battery connector. The locks on both sides of the keyboard connector were popped out.


It is a lot easier to insert the keyboard cable and make sure it's in the socket as far as it can go if the battery is out of the way. That said, the battery doesn't have to be disconnected (and that connector is pretty hard to remove). The wires are long enough to simply (and carefully) rotate it out of the way.


I replaced/added tape over the connectors when I was done and all the keys are working again.

Craig Prall - Reply

Thank you so much! I was just about to begin a big project on my Asus Zenbook when that keyboard issue developed, and I went to Radio Shack to buy the Torx T5 --they told me they didn't carry that screwdriver because the tech companies didn't want folks poking around in electronics. Sheesh! She told me I'd have to order it online... luckily there was a Home Depot down the street and they had the screwdriver kit. I was hesitant, but once I began the entire process took less than five minutes and I'm not having to use the onscreen keyboard! :)

Thank you so much for this great easy-to-follow fix!

Brian Kaufman - Reply

Great Fix! Thank you 100 thousand times!

I found the T5 fit just right, it was the #1 phillips that was off. the #00 fit just fine, the #1 was too large.

But once again, great fix! Saved a laptop I love.

Kevin Malone - Reply

Thanks! Solved my problem with power button and control buttons.

I think the connector design is flawed: even if you press both ends at once, it wants to click back out. I tried to press also a bit _under_ the ribbon cable with a screwdriver (gently!), such that the whole connector would fix better.

Henk - Reply

worked like a charm. An absolute life saver. I used a scotch tape to keep the connectors in place.

halayuda - Reply

Worked great! I initially thought it might be a software issue because the problem with some keys would come and go and often went away after a reboot. After the reboot trick proved unreliable, I found your fix. This solved the problem. Thanks for sharing your fix.

heathbar - Reply

PERFECT! So easy. Thank you.

Jennifer Garcia - Reply

Excellent page....I am glad I found this. Three days after I bought my new Asus Zenbook, I ran into this issue. Sure enough, instead of sending it back, I tried your suggested solution. The keyboard has been working nicely since. Keeping my fingers crossed, because I like everything else about this laptop.

amitramani - Reply

Just wanted to say thanks for posting this guide...just got some nice bonus points with the girlfriend.

Matt - Reply

I got my open box zenbook for an exceptional price and started getting the keyboard issue intermittently from day one. I was absolutely livid and figured it was a lesson learned re open box products.

Found this post after a bit of research, perfect step by step guide. Resolved issue immediately. Very simple fix, incredibly satisfying to bypass Asus for this.

Many thanks to OP.

Sean McDade - Reply

Sorry guys, I tried to this but it didn't work for me. I put the white connectors back in but my 2 arrow and ESC keys still unresponsive. Anything else I could try? ASUS wants to charge around $100 to fix it (out of warranty).

Next step would be to try to replace the whole keyboard.

Bo Sun - Reply

I had the same problem with a Zenbook UX21A (principally the X key); the layout is slightly different once you get the cover off, but otherwise exactly the same solution worked perfectly. Thanks!

Steven Pemberton - Reply

Thank you so much ! Very easy to follow, very easy to do and works like a charm.

DocBrown - Reply

OMG...after multiple hours wasted with ASUS support and reinstalling ATK-drivers, I finally got the quick and easy answer I was looking for HERE! Thank goodness I didn't reinstall the OS as ASUS was recommending I do.

With your simple instructions, I opened the aluminum case, and there I saw one edge of then keyboard connectors had sliped out. After pushing both sides in, I replaced the cheap tape with stickier electric tape and restarted my UX31A ultabook.

The more dead keyboard keys!

Thanks again. I am really surprised ASUS support had no idea about this.

sampson - Reply

Bummer - ASUS UX-31E

I had high hopes for this, my T and Y keys are unresponsive. They work if I hold down for a brief second so maybe that is why this fix didn't work for me. Took the back off everything was as described. I had a feeling my problem was different when the cable had no tape on it and was fully seated in the connector. I pushed it in but there was no movement. Put everything back together problem still exists. Does anyone know how to replace the keyboard or if it is even possible?

dan - Reply

I have the same problem as you Dan.

Have you been able to fix it since? what solutions could you give me ?

The clips didnt seemed popped out. I pushed them together. Still after a few tries my random few letter keys do not work.

Hugh -

I have the same problem!! Started a few months ago with the letter “y”. I found that presing fn+the left it will work, I did that the first and second time and it did work. The third time it didn´t work anymore, but suddently, after a mounth started to work at of nowhere, now again, isn´t working. Don´t know what it´s going on with the computer.

Blanca -

This fix seems to have worked for me too! - but it looks like it is not a permanent fix - someone was supplying clips for a permanent fix but it looks like they are not available anymore? Thanks for the great guide!

Philip Rhoades P - Reply

Once again, IFixIt saved me hours of time ... or in this case, an entire 10-day business trip without the letter "d"! Yay Ifixit!

Josh Berkus - Reply

Thank you! Worked perfectly and solved the problem in under 5 minutes.

Christian Bratt - Reply

Some other people here mentioned doing the same fix for the UX32A. When I remove the back cover it looks different enough from the pictures above for me to be confident about what I'm doing. Does anyone know where I can find pictures for the UX32A?

Gabe - Reply

I think the fact that pressing in on one side of the holder causes the other side to pop out is the clue here.... it is in fact a single wide holder that goes under the ribbon to hold it firmly in place. The reason it pops out on alternate sides (and most likely the reason it becomes loose again over time even after pressing both sides in together) is that the hidden middle section of the holder is not going in firmly as it should. To remedy this, best to remove the battery (unscrew then twist gently out of the way) then insert a thin flat screwdriver or similar under the middle of the ribbon cable to press the holder in at that point also. I imagine tape would help to keep the ribbon inserted, but if the holder continues to pop out (because it is bent out in its middle) then the contact could still be dodgy and keyboard issues may still occur.

peterbig - Reply

Make sure you get a good quality torq driver as the cheap one I got from Amazon almost stripped out the last screw before I could get the cover off. The fix worked great, I was having trouble with both the power button and shift keys, they are working great now!


Tony M

Tony Majszak - Reply

Brilliant. worked a charm. Thank you. Hope Asus reads this post.

Brian - Reply

I've been using the Win 8 screen keyboard for about two months until I came across this iFixit. The procedure worked here with a different computer than the description. Have a lighted keyboard and touch screen ASUS N-Series. Taking the screws off the back were not the same but similar. Took the battery out with three screws to "recognize" the keyboard plugin. It looked the same but way smaller than I thought. Only about an inch wide. Finally confirmed it was the connector and started pushing both ends until I felt a very slight click. Replaced battery - all went well - and got my keyboard back. Thanks a lot to who published the Fix. BTW I used a 34 Piece Precision Screwdriver set from Harbor Freight. It had everything I needed.

Richard Korgan - Reply

If the tape isn't holding well enough, check out my tweak to this guide! (P.S. major thanks to the original author, I've used this fix a hundred times over.)

Asus Zenbook UX31A unresponsive Keyboard fix

Clarissa - Reply

Thanks a lot for this guide. It is also very useful for those (like myself) who have the same problem with their ASUS UX32VD (no need to remove the battery at step 2).

Daifulei - Reply

Hi Daifulei,

I am having this issue with my ASUS UX32VD as well. Any chance you can direct me to a screenshot of where the keyboard connection is on that model? Mine does not look like any of the pictures posted. I would be very grateful for any help you can offer.



Andy -

The tape only works to keep the ribbon inserted in the connector; it doesn't keep the connector locking mechanism from coming loose. This is NOT a permanent fix; I've gone to putting a T5 into my laptop bag so I can fix it as soon as the symptoms appear.

Jim Millard - Reply

I cannot believe that after a week, AND buying a new keyboard ( because I couldn't get a single key to work) It's fixed. My fault totally, as I didn't realise these little locks were there.

I've been searching all day every day and night..keyboard not working, unresponsive keyboard...every way I could think of putting it online. You are magical!!!

Thank goodness I found your IFIXIT site, or I'd still be online searching for a way to fix it. I'm so happy, I could dance.

Elaine - Reply

Great !!

It took 5 minutes to repair this little annoying issue.


A C E - Reply

I fixed my computer with sticky tape! Awesomely clear guide, with first class results, many thanks! Mark

markwilson - Reply

Like most, my power button and shift keys were not working, followed the guide and works perfectly now. Agree with the poster to use mini (jewelers) screwdrivers so you can push down both tabs at once, as when you push one down the other pops up. Then used electrical tape on the tabs, then put a piece of tape over the whole top. Worked like a charm. Didn't need to remove the battery.

John Harper - Reply

Asus Zenbooks have a horrible horrible design flaw. The power button is part of the keyboard, so if your keyboard stops working, you can’t turn on the laptop. Specifically I have the ux301-dh71t, and a single drop of water fell on my “up” key. Due to the keyboard not being water resistant this drop of water eventually corroded the keyboard circuitry, killed a bunch of keys around it and eventually the power key too. There is no other way I found to turn on the laptop, other than opening the back cover and short circuiting 2 pins on the keyboard connector (wide blue ribbon). In order for this to work you need to have the notebook partially open otherwise it won’t turn on. Be very careful not to short circuit other stuff. I was able to get it to turn on by short circuiting the 1st pin and the 4th 5th or 6th (not sure exactly since they are so small). The first pin would be the one closer to the power button side. I then connected a usb keyboard and proceeded to download my data.

techguy - Reply

Replacing the internal keyboard is not an easy task at all, there are about 60 screws and a dozen connectors you need to remove to get to it. ASUS did a horrible job here, with such a vulnerable hard to replace keyboard which is unfortunate because it’s an amazing laptop. The power button should always be separate from the keyboard. Normally I would have popped the ssd in another computer but these are dual raid 0 ssd’s, not an easy data recovery task.

techguy - Reply

Hi, thanks for the great guide which seems to have helped a lot of people. I have the Zenbook UX301LA and am having the same problem (for me it's the 7, 8, U, I, H and B keys that are not working. I'm now typing on the virtual keyboard - first use I have for the touchscreen).

I opened it to see if I could fix the problem but the motherboard is not the same and I couldnt find the loose connector. Did anyone have the same problem with a UX301LA and fix it? Thanks a lot! I'm desperate

DrIndecis - Reply

Just like DrIndices, above, I have lost the use of 7, 8, U, I, H and B keys on my Asus Zenbook UX301A. I have resorted to sprinking Bluetooth keyboards around my home and office.

Since the non-working keys are situated along a diagonal line, it seems reasonable that there may be a loose connector to the MB (i.e. One strobe line is not making contact). But I have opened the Ultrabook, cleaned the contacts, re-seated the ribbon cable, and triple checked the ZIF connector -- all to no avail. I don't know if the problem lies in the keyboard, cable, connector,or motherboard logic. It is infuriating.

Having to carry around a keyboard, my svelte Ultrabook is not so "ultra" anymore. If the problem hits the power button, I will be totally scr*wed. This is a $2K machine and my local PC repair shop is stumped. Any suggestions would be appreciated.

Please reach out by phone. I would be grateful.

Phil R. in Boston

Ph: 5O8 / 485 ..6950

Philip Raymond -

Great fix - just solved my long lasting hassle waking the system up or even powering it on from time to time! This saved a thought before shipment to Asus service too. They might have replaced the motherboard or another part in several weeks and I would be happy too, and now I am happy right away just after this DIY ten minute fix!

dmitrinovikov - Reply

My Control Keys quit working. Some initial searching suggested keyboard replacement.

I'm glad I searched once more and found this.

I ended up just adding a dot of hot glue to the corners of each tab, touching the motherboard. This way once it dries, it should give it some grip so the tabs can't work their way back out again.

Joe Stillman - Reply

Thanks a lot. Ultrabook working perfectly again.

Walter - Reply

Awesome fix, thanks!

4estnet - Reply

Thank you so much! I had been struggling with this problem for several months (most of the times I could not power on my UX31A computer unless I tried again and again...) and your solution has solved it: it is most appreciated!!!!

Pablo Martín Ramos - Reply

Folks, I had tried this fix two times. but I still have the same problems. Any ideas?

Shady Hegazy - Reply

Pro tip: If the power button goes bad and you need to turn the laptop on, techguy’s solution works great: “…There is no other way I found to turn on the laptop, other than opening the back cover and short circuiting 2 pins on the keyboard connector (wide blue ribbon). In order for this to work you need to have the notebook partially open otherwise it won’t turn on. Be very careful not to short circuit other stuff. I was able to get it to turn on by short circuiting the 1st pin and the 4th 5th or 6th (not sure exactly since they are so small). The first pin would be the one closer to the power button side.  “

klobber12.2 - Reply

Thank you ! You saved 25 dolars and a half day!

sevanalpay - Reply

Worked great, thank you author!

Dave Pease - Reply

Add Comment

View Statistics:

Past 24 Hours: 6

Past 7 Days: 25

Past 30 Days: 69

All Time: 172,964