No Category

No Category

This page hasn't yet been categorized. Our admins will be around to organize this content soon!

No Image

No Image

This wiki is missing a device image. Help iFixit by uploading one!

No Summary

No Summary

This wiki does not have a summary. Help iFixit by writing one!

Page Stub

Page Stub

This wiki page is a stub. Help iFixit by adding information to it!

Support Questions Ask a Question

There are no questions. Be the first to ask a question!

Hi, so I just got a camera from my aunt who said it stopped working for her, so she asked me to take a look at it and see if I could fix it and if I could, I could keep it. So, when every I push the live veiw button ,the screen will go black and the only way to get back to the menu is to turn the camera off, take out the battery, then put it back in and turn it on! Also when the camera was working you would take a photo and it displays it for 2 or so seconds, but when I take a photo now the screen will go completely black when it should be showing my photo. When I go to press the play button to look at my photo library the display either says “no images”or”busy...please wait” even though I know I have pictures on my SD card! And as if all this wasn’t enough, when I turn the switch to the off position, it says recording images please wait!!! I’ve bought(and tried) a new SD card, a friends lens, and updated the frimwear! I have knowidea how to move forward, and if it’s even worth it to try and fix it! Any help is appreciated, thanks

View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 4

All Time: 40