Model M7572 / 400 or 500 MHz G3 processor

51 Questions View all

My generic ac adapter will not power on my Pismo

I purchased a generic ac adapter for my Pismo and it does not work. I am not sure if it is a 45W or not. Should I have purchased a 65W?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Thanks for your help. Here’s what going on; I purchased the Pismo G3 PowerBook used but it did not have the original ac adapter so I purchased a new generic one from the internet (M8482). It still would not power on so I purchased a new PRAM battery, still no luck, then I replaced the power card and DC sound card, still nothing. I tried doing all the resets, but still nothing. Then I purchased a rechargeable battery (M7318) and it powered on and it worked until the battery went dead. So as you said it may be a defective adapter or that it is incompatible. Any info would be appreciated.

by

At this point I believe the adapter you received has problems. Please see if you can borrow one from someone long enough to see if that's the problem. Since you can boot with a charged battery its likely that your logic board is good. Ralph

by

Add a comment

2 Answers

Chosen Solution

Follow rj713's adivce, it could be also (as he says) a bad DC in board. If you're sure the charger's good then that's what's most likely. I doubt a PMU reset would make much of a difference, but it's pretty easy to see if the charger's good or not. If you purchased from a shoddy seller then it's very likely it's bad, wires get broken easily.

If you end up needing a new DC-in board, here's a link.

If you end up needing a new AC adapter, here's a link.

Some advice for using those pismo chargers though, when leaving it charging, either fully unwind the "Yo-Yo" or leave it next to your computer, not underneath or above. The problem with the "Yo-Yo" style (which prompted them to change the cord style in later G3s and then G4s) was that the coiled wire carrying a current turned it into a solenoid, which creates a magnetic field, which means bye-bye for your hard drive. Just some advice that'll keep your pismo around a lot longer.

Was this answer helpful?

Score 0
Add a comment
Most Helpful Answer

No that unit uses a 45w adapter.(M7332) More likely its either a defective adapter or a bad DC in board. Do you have another adapter to try? Does the computer start up with the battery? Ralph

Was this answer helpful?

Score 1

Comments:

Here is the URL for doing a PMU reset. Try it if you either don't have another adapter or a different adapter doesn't work. Ralph

http://support.apple.com/kb/HT1431?viewl...

by

Quality answer +

by

Add a comment

Add your answer

Janice will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,125