Apple's line of MacBook Pro laptops was intended for the professional and power users. The MacBook Pro line includes the MacBook Pro 13" Unibody, MacBook Pro 15", MacBook Pro 15" Unibody, MacBook Pro 17", and the MacBook Pro 17" Unibody.

10407 Questions View all

Wi-Fi "No Hardware Installed" even after replacing wi-fi card

So I've been fighting the wi-fi "no hardware installed" bug for sometime, on my early 2011 15" MBP. I tried replacing the drivers to no avail. Wi-fi is not available when booting to the OS X restore CD, nor at the boot drive selection screen (holding "option" at power on). I still have bluetooth connectivity.

I recently bought a replacement wi-fi card from iFixIt, and that also did not resolve the issue.

The computer is out of warranty.

I've run out of ideas. Does anyone have any advice?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

I have been fighting the same battle. I've had my laptop open many times. I did replace the card myself, the problem didn't go away. It is intermittent. I've tried all the wives tales about fixing it - resetting SMC / PRAM, etc., but nothing definitive works. Also deleted my sleepimage and turned off hibernation. I just re-seated the card connector and made sure that it was taped securely to the wifi assembly. The wifi came on again. We'll see how long that lasts.

== Update ==

I should add that I went back to the original wifi card, since it didn't work and for some reason with the new (after-market) card, I lost bluetooth.

by

Stanley Swiniarski- For future reference you posted a comment/Question in the place where only Answers belong.'' Please use the comment link.

by

Add a comment

2 Answers

Chosen Solution

Of course you remembered to enable the airport interface via SystemPreferences:Network after installing the new one, and turn it on. Try holding N key down for Network boot (I'm not certain wireless support is loaded at restore or option boot). Check in System Profiler:Network or Wi-Fi to see if the OS detects the card. It's possible the connection is not complete...remove and inspect the card connector for corrosion, or defects. If none of that helps contact iFixit Customer Support directly (this is the volunteer help forum).

''If this answer was helpful please remember to return an mark it Accepted.

Was this answer helpful?

Score 0

Comments:

Thanks -- yes, I did attempt to re-enable the airport interface in System Preferences, but it does not appear in the list of available interfaces. At the option boot, the system does attempt to scan for Wi-Fi networks, but fails and populates the drop-down with an "X". I did not try network boot, yet, but can also confirm the airport adapter is not available when I boot to a Linux LiveCD image, nor does it appear in System Profiler when booted to the laptop's restore DVD.

I've also been in touch with iFixIt customer support, but to no avail... which is why I turned here, to see if anyone else encountered anything like this before.

At this point, I suspect it's a failure on the main logic board.

by

Yes there or the card connector... or even the card. If you can't enable it the software isn't detecting it.

by

Add a comment
Most Helpful Answer

I know this is an old thread, but if anyone finds it, it sounds like replacing the ribbon cable is the way to go:

http://warrantyvoidifremoved.blogspot.co...

Why does the wifi only work intermittently?

Was this answer helpful?

Score 1
Add a comment

Add your answer

tim will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 20

Past 30 Days: 96

All Time: 10,476