Model A1103 / 1.25, 1.33, 1.42, or 1.5 GHz G4 processor

74 Questions View all

How to upgrade the cpu?

I have an older mac mini that cannot run snow leopard and to become a developer for apple you need snow leopard and i was wondering if upgrading the cpu would allow me to do this.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

The processor is mounted directly to the motherboard. To run Snow Leopard you need an Mac computer with an Intel processor. You can not put an intel processor on a G4 logic board.

Your best bet would be either buy a new mini or get an early model intel version which can be upgraded.

If this answer was helpful please remember to mark it accepted.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Seth Potter will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 14

All Time: 1,118