Model No. A1367 / 8, 16, 32, or 64 GB capacity

1275 Questions View all

The display isn't turning on despite being powered?

Question above. The digitizer (that's the black ribbon cable, right?) is intact, but the little chip on a short ribbon appears to be disconnected (I think that's the display cable). If this is the problem, how do I resolve it? If not, what information can I give? Thanks in advance!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Yes, that is your display cable. If it is severed, the entire screen assembly will need to be replaced.

Best of Luck,

Tough Gaming Technical Support

Agent Elisha

Was this answer helpful?

Score 0

Comments:

It's not severed. It's just the chip at the end of the cable is not connected to the little piece where it's supposed to be connected. In that case, how do I get it back in there?

by

Can you post a image? That will help greatly.

by

Sorry I'm a bit late: images here. http://imgur.com/FpW7O,lOiNA

by

I see what your problem is. Just align it up and press down. Make sure that is aligned with the chip on the mainboard before pressing down, ad you may break the connector on the mainboard. This connection is required to get the LCD Display Screen to work, it the same as the one undernieth. Best of luck,

by

Add a comment

Add your answer

Lorenzo Batallones will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 224