Repair guides and support for gas, electric, and human powered machines used to cut grass, whether push style, or ride-on.

607 Questions View all

Lack of power and whinning

After running my JD mower for about 10 minutes, there is a whinning and lack of power, especially going in reverse. After 30 min. not enough power to go up a small incline.

I have put on a new drive belt and sprayed it with a belt dressing. No change.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

First question is what model John Deere mower do you have?

Belt dressing is a lubricant that stops squeaky belts but unfortunately does nothing to help make the belt grip the pulleys better. In fact, quite the opposite.

If your mower has a hydro-static drive transaxle, then it might be low on fluid and is starting to slip. Once we know the model number, then we can look up some specifics.

BILL

by

HemiBill

Thanks for your response. I have a John Deere STX46 with a Hydrostatic drive. I have never added fluid to the transaxle in over 6 years.

Should I drain it and add new fluid? Is there a fluid filter? What type fluid should I buy?

Thanks

Tom

.

by

Add a comment

1 Answer

Chosen Solution

From what I've been able to find, there is a filter and a fluid fill point, but both sound like a pain to access. Another site says the transaxle is a "sealed unit" which usually implies there is no servicing available.

Service and parts manuals are still available through John Deere. Here is a list of them: manuals

Hope this helps,

BILL

Was this answer helpful?

Score 2
Add a comment

Add your answer

tom will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 360