Model A1174 with 2 GHz Core Duo or Model A1207 with 2.16 or 2.33 GHz Core 2 Duo

265 Questions View all

No Response even after power supply replacement. Please Help!

Hi

One morning found computer was turned off and had to power it back on and seemed to work fine but after about five minutes the system turned off as though the power cord was removed. Found how to diagnose the problem but found no LED's were on therefore replaced power supply. Now the power supply was replaced and tested successfully but still no response. Out of ideas please help. My EMC #2118.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Take a look at the diagnostic LEDs and tell us what you find. Where did the replacement power supply come from? I hope not eBay.

Was this answer helpful?

Score 2

Comments:

The LEDs are not on. The new replacement was purchased from DV Warehouse.

by

LED #1 should be on even with a bad power supply. Try changing your power cord and check your wall plug, you may have blown a fuse. This is an unusual problem, so don't buy anything without talking to us first.

by

I checked the power cord with a multi-meter and power is coming in but no lit up LED's. I also check the voltage from the new power supply and it reads 18V AC so it seems to be responding. Also checked for any discoloration on the logic board but everything seem to be fine.

by

First I'd check the old power supply and sent the new one back if you're getting the same readings. My suspect is now the logic board but I've never seen one fail and give out no diagnostic lights.

by

Add a comment

Add your answer

Danny will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 598