Released June 2009 / 2.66, 2.8, or 3.06 GHz Core 2 Duo Processor

278 Questions View all

Problem with Toslink optical output

Hi, I'm having a problem with the toslink of my MacBook Pro (MBP Unibody Mid 2009, 2.8Ghz Core2duo), when I plug a headphone or another mini-jack cable no problem with the sound, but if I plug an optical cable no more sound.

I know how to make it work because it worked before, then not so well I had to move the cable a bit the get the sound, then it got worse, and now no sound at all...

I can still see the red light at the other end of the cable and I tested it with another MBP and it works, so I guess the toslink connector is either dead or something near...

Is it hard to replace ? or could it be fixed ?

I didn't want to touch it before having an expert's advice.

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

3 Answers

Chosen Solution

Yes, the last update killed the digital in/outputs.

Just got back from the Apple store talking with them. It was rushed do to the malware mess and they guessed the new models where used for QC.

Turns out the new MacBook Pro's don't offer digital in/output ports anymore! So they failed to properly qualify the update. Now Instead they offer a HDMI port which is not workable for a sound engineer.

Backing off updates are a real pain!

Was this answer helpful?

Score 1

Comments:

Ok ! that's a shame, no digital output... well I will install Snow Leopard on an external drive and boot on it to be sure, I hope it's the updates and not the hardware...

Thanks for the answer, will be back with the result of the test.

by

Add a comment

I have the same issue. It started just after the latest software update from Apple. I've troubleshot the problem using two audio systems and another computer. The audio systems and the cable are not the issue, they work fine with the other computer, which does to have the updated software.

I was on with tech support for over an hour and the issue has not been fixed. They suggested reinstalling the operating system as it was before the update. Will try that tomorrow.

Update

After spending two days troubleshooting with Apple's Senior Tech Support they concluded the issue is the with the digital-optical port driver. It doesn't work with the latest OS 10.7.4 update. They suggested I contact the manufacturer of my DAC. I did, and here is the response:

"This is the first I've heard of this exact issue but we have been hearing of a few issues with Apple's OS when they've done update changes. They have been having some wifi issues that are causing other problems too. Starting to sound more like Microsoft every day.

This is a driver in the Apple device controlling Apple's digital toslink output. It is not something that we could provide because it is an Apple issue in an Apple device. Unfortunately you will have to stay on them to get this driver updated. Hopefully and typically they are fairly fast.

The input on the CD306 is just a standard digital toslink input and has no special needs. Stay on Apple and watch the forums for assistance. The more people write or call them the faster you will see the driver.

This is your best shot."

Was this answer helpful?

Score 0
Add a comment

Hey, I have this problem too. It's a shame it was an update problem. I should've figured it out. I almost broken my input plug thinking it was something like that. The red light still appears on the other side and on an airport express, this same cable works fine. Can't this be updated somehow?

Was this answer helpful?

Score 0

Comments:

Not sure I follow you here... The system was a MacBook Pro in question, not an Airport express. The digital optical signal will only be present on the Rx side of the connection and you do need to have a digital input on the device for the signal to be used (optically vs electrically).

by

Dan, so sorry for not seeing this before. What I mean't was that the other side of the cable was red which means the output device on the MBP is working fine. Just saying the cable and the device are fine. So, the issues must truly be driver related.

by

The newer updates fixed this flaw. Where are you on you on your updates?

by

That would be great, although at the moment I'm using the El Capitan beta 6 and it still doesn't work. Every update before has been the same - no audio.

by

mmm ... What happens when you put in a standard mini plug in does the sound on the internet speakers cut in and out as you push and pull out the plug as the music is playing?

by

Show 1 more comment

Add a comment

Add your answer

Juan fidel will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 43

All Time: 3,841