MacBook Pro will not boot properly

About two weeks ago a small amount of water was spilled on a friends macbook pro. It has been sitting since then and I decided to see if i can get it running.

When I press the power button (as one normally would when you start a computer) I can hear the HD try to spin for maybe a second or two, the front indicator light comes on, and then the computer shuts down immediately...BUT, when i hold the power button down for about 5 or so seconds, the hard drive will spin up and after the front indicator light blinks at me I can release the power button and it will boot as normal and run like a champ.

I am tech savvy but do not own a mac so please forgive if I don't use apple speak :)

FYI: its out of warranty

I have already performed the following tasks without any luck: reset NVRAM, installed new HD with ghosted image of original HD, taken the battery out to cycle power, tore the MBP completely down to the bones and cleaned the heat sinks and thermal paste (yes i applied new paste).

I am currently working on acquiring an OS disc (Snow Leopard) to try a clean install and see if that helps....

ANY IDEAS???

Cheers,

Wyz

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment
Black Friday
Broken doesn't stand a chance.

4 Answers

Chosen Solution

Try resetting the SMC, here's how: http://support.apple.com/kb/HT3964

Was this answer helpful?

Score 2

Comments:

I tried resetting the SMC as suggested. Is there any way to know it has been reset? The light on the power supply never changed or cycled. Anyway, no luck, same situation. It seems very odd to me that if I hold the power button in it starts up...almost like i am overriding a setting or sensor. Also, I ran AHT and got the error: "4sns/1/40000000: IPOR - 9.166" Thanks for the help! Any other ideas?

by

Add a comment

I have the same problem. But also cou will not clock higher than 800mhz. Not found a way of fixing it yet though!

Cpu would also use 100% unless in safe mode. But theres a file you can delete to stop kernel using all cpu.

Was this answer helpful?

Score 0
Add a comment

I have this same issue as well. Not sure why this was marked answered if it didn't resolve the issue....

Was this answer helpful?

Score 0
Add a comment

same problem here. solderd an brand new ic i625 still same issue

Was this answer helpful?

Score 0
Add a comment

Add your answer

Nick will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 12

Past 30 Days: 37

All Time: 2,277