Mid 2006 / model number A1181 / black or white case / 1.83 or 2.0 GHz Intel Core Duo processor.

509 Questions View all

MacBook will not boot

I have a 2006 White Macbook 1.83Ghz Model A1811. I has served me well in the past years. About a year ago I replaced the hard drive and RAM and it worked beautifully. The disc drive has not been working for a while and I wanted to be able to back up all my inforamation on hard disc so I ordered the part and replaced that as well about a month ago. Everything went well and I was able to back everything up. Unfortuniately, a couple weeks ago after flying overseas I turned on my Macbook and the tracpad was unresponsive, so I rebooted. Upon restart the some of the keys failed to work as well, so I did another restart. Now the power button does not work and I cannot boot at all. The battery is fully charged, the adapter works as the light tuns orange when charging the battery. Are there any simple diagnostic test to let me know if the problem is the keyboard or something more serious like the logic board.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I had a very similar problem to your on my early 2006 2.0 GHz MacBook. The problem I had was that during transit my keyboard connector became loose and as a result the power button didn't work to turn on the computer. What you can do is follow this guide:

MacBook Core Duo Upper Case Replacement

...to remove the upper case and check that connector on the last step that carries the keyboard/trackpad/power button signals. If you pull the cable out and put it back in it may fix the problem. If it doesn't fix the problem then take a flat head screwdriver and do what is seen here in this video:

http://www.youtube.com/watch?v=_cnXsKBX5...

.... if you have a broken top case then it will turn on but if it still doesn't turn on then you most likely have a logic board problem and will need to get a replacement. If you try this get back to me and tell me how it went so I can give you any further assistance if needed.

Hope this Helps.

Was this answer helpful?

Score 2

Comments:

Thanks! I removed the upper case and used a screwdriver and it booted right up. I guess the next step is to replace the cable/ topcase. Hopefully I can find one here or have it shipped overseas to me. Thanks again!

by

Add a comment

Add your answer

Thomas will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 658