Model A1225 / Mid 2007 and Early 2008 / 2.4, 2.8, or 3.06 GHz Core 2 Duo processor

424 Questions View all

4th LED on logicboard is not on

I am experiencing the same issue, at first the iMac froze and then i proceeded to shut it off. Then, I turned it back on and there was no chime, picture, or even a back light from the LCD but I could hear the fans and drive spin up. I took the iMac apart and checked out the LED's the first LED lit up after plugging it in, the second lit up after turning it on and then the third one turned on shortly afterwards, then they all turned off and then came back on again.... but the fourth never lit up at all during this process. I would assume the logicboard is at fault due to the nature of it not giving me any visuals and or post chime. I know that sometimes when PSU's go bad the internal fans and drives can still turn on if they are operating on a separate rail. It's either of the two I just cant figure out which one.

HELP!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Well it turned out that my lcd screen was fine. My last resort was the power supply which turned out to be the problem. That in turn took out the logicboard. In the end it was the power supply and logicboard that failed. I have read about this problem on other sites and seems to be one of the more common failure points.

I am not an expert enough to suggest that this is your problem, but it sounds awfully similar.

by

I am at least getting power and the first and second LED's lit... But I just cant figure it out.

by

Add a comment

1 Answer

Chosen Solution

LED #3

Indicates that the computer and the video card are communicating. This LED will be ON (turn on and remain on) when the computer is communicating properly with the video card. If LEDs 1 and 2 are ON and you heard the startup sound, but LED 3 is OFF, then the video card might be installed incorrectly or need replacement.

I can't tell from your question if the LEDs are just flashing on then off. After the machine has started, what lights are still on after a minute?

Was this answer helpful?

Score 2

Comments:

All but the fourth turn on but initially, 1, 2, and 3 turn on. turn off and then turn back on and stay on but the 4th never lights up at all period.

And I am not getting any picture at all nor is there a back light on the LCD. I can however, hear the drive spinning up and see the fans spin.

by

Hook it up to an external monitor and let us know if you get a picture. Thanks

by

UPDATE:

I've been busy lately and haven't been able to hook it up to an external monitor. But today when i had time I attempted to give it another shot and now all LED's but the fourth (like before) come on and then turn off and continue to power on and off, its like the iMac is attempting to restart over and over again until I pull the plug.

by

I also hooked it up to an external monitor and was getting the same issues stated earlier in this post.

by

UPDATE: It was in fact a mobo replacement that was needed. Thank you all for your help, I apologize for not logging on as much as I should. =P

by

Add a comment

Add your answer

Gill will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 14

All Time: 1,305