Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1390 Questions View all

MacBook Core 2 Duo doesn't recognize topcase

Hi!

Pleae help me.

My Macbook does not recognize the topcase. I can start it without the topcase and work with an external keyboard but its not really a solution, because i have to start it with a screwdriver evry time i want to use it. I am sure the topcase and the cable are ok, i tested them on another macbook. Any thoughts? Is it possible to refresh the topcase-connector somehow? Thanks in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Please tell us more about this. Is only the power on button not working on the top case? Does either the mouse or keyboard work on the upper case? Are there any bent or missing pins in the the header/socket on the motherboard where the cable connects? Are the solder joints for the header/socket/connector intact? You will need a good magnifier to inspect for the last 2 questions, I suggest 10x or better - jewelers loupe being the cheapest and easiest to locate. The keyboard/trackpad of the upper case are piggybacked into the USB controller, technically they are USB devices. Are you having problems with any other USB devices or ports? Do you have a multimeter and are you comfortable using one? What are the last 3 characters of your serial number? - Need those to determine your exact machine and be better situated to address your problem. While you are working on answering these questions I'll track down the pinout for the connector in my archives.

by

Thank for the reply, i really appreciate it. I do not have a magnifier and a multimeter at the moment, but i am comfortable using both so i will borrow both from my father and start from there.

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

If you tested your top case on another machine and it worked, try testing the working top case from the other machine on yours. What is the history of this problem? Have you had liquid damage? Inspect the logic board receptacle for foreign material or damage.

Was this answer helpful?

Score 4

Comments:

Thanks for answering. I tried both topcases on both machines. They both work on a the working machine, and both dont on the faulty one. Some liquid was spilled on the topcase of the faulty one, but really not much.

by

It appears the problem is with the logic board. Hook up an external keyboard, start the machine up from the logic board and let us know your results. Water may have gotten through to the logic board and shorted it out.

by

Add a comment

Add your answer

Maxim Proleskovski will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 393