Model A1040 / 10, 15, 20, 30, or 40 GB hard drive / four touch-sensitive LED backlit buttons above touch wheel

96 Questions View all

iPod freezes at Apple symbol and I can't restore it.

I have a 30GB 3rd Generation iPod (A1040) that is having trouble. My iPod starts up, but stops at the apple logo and does not go any further. I have tried the iPod diagnostic drive scan (<<, Menu, Select, >>) and it stops with the error symbol. I have also tried the diagnostic tools and the HD test comes back saying the HD is bad.

However, when I set it into disk mode and connect it to my iMac, it shows up and I can see the disk in "Disk Utilities" and iTunes. I have scanned it with TechTools' surface scan, and it tested ~58k blocks and came back with no errors. I formatted it in Disk Utilities with the zero out all data option. Still no luck.

When I try to restore the iPod, the installer runs and says its finished and that the iPod is restarting... but the iPod just sits there with the 'OK to disconnect' check symbol and never restarts. When I reset it (Menu, Play/Pause), it starts up with the apple logo with a loading bar underneath which fills up and disappears. Then the apple logo comes back up and it freezes there. (Seems like it does not load the firmware restore properly to me...)

The battery is decent and I am doing all of this with a firewire dock cable... It seems to charge fine.

What is going on? Has the logic board gone bad, is is the firmware on the hard drive corrupted and not reinstalling?

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Having just had similar on an iPod classic, I put it in recovery but it wouldn't restore, said ok to disconnect.. Charged up again, switch off Mac, removed extra plug in/USB, restarted Mac and wallah! iPod is restored.

by

ha! ha! that'll teach me to think I'd sorted it out.nope, error message. Am trying to erase ipod via mac instead. I'll be interested to see how you get on, I'm thinking of following some advice to try erasing /reformatting using windows.

by

turns out my ipod had the wrong motherboard/logicboard in for the rest of the parts...the risk you take buying secondhand.

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

give this a try, toggle the hold button about 5 times, then hold the enter(middle button)and menu and the same time for about 10 seconds. The apple sign should come up after that which means you unlocked it. The only other thing I would suggest, is that you try and format your iPod HDD through your OS. After that try and restore through itunes.

Was this answer helpful?

Score 1

Comments:

No luck with that. The keys are not locked, and I have no problem getting the apple sign to show. Getting it past the apple logo is the problem.

I have already tried formatting with disk utility, which worked. I have also tried restoring it in itunes, but that does not complete properly and the restore seems to fail.

by

Add a comment

Add your answer

Christopher will be eternally grateful.
View Statistics:

Past 24 Hours: 4

Past 7 Days: 8

Past 30 Days: 19

All Time: 3,000