LED 1 on but no Boot - No visible bad Capacitors

I know of the common problem on these powerpc Imacs. However this one does not have the same visible damage that I would expect. here is what I know so far...

- The LED 1 light is constant on.

- The power supply has no blown or buldging caps

- The Logic Board does not have any blown or buldging caps.

- I have switched out the RAM stick and it is not the ram.

what is another area to look? I don't have any other G5's to test against.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

This power supply will light up #1 LED even if it is bad. It's the most common failure I've seen on these machines. I get them rebuilt 3 at a time out of Utah. You can also get the caps on eBay. The guy that knows the most about this is Jim Warholic. http://jimwarholic.com/2009/04/apple-ima...

Was this answer helpful?

Score 2

Comments:

I went to Jim's site and that has great info, however he is not willing to do repairs. He recommended someone else at $59 a unit. Do you or anyone know of someone else? Maybe at a lower cost?

by

Actually $59 a unit, exchange is a good price. If you don't mind, please tell me who he recommended. Thanks

by

In a followup to this I have heard that the POWER SUPPLY suffers from another issue than bad capacitors. The guy would not explain but said he knows what the common issue is...

Sounds like protected information for job security :)

by

Add a comment

the same thing happened to me! led 1 was lighting up, but not led 2. so i replaced the logic board. and it;s still the same. I wish i would have known that led 1 will light when the power supply is faulty. the only thing im willing to do is replace the power supply. after that, am totally giving up.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Erik will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,371