iPod 4th Generation lock button not working, volume buttons work.

So, this is not my first iPod 4th gen repair, I have extensive experience repairing all apple portables. But I am faced with a conundrum, let me explain.

I am working on an iPod Touch 4th Generation, it had been dropped once, and the digitizer had been replaced. It was dropped again and came back to me for the same repair. This time I replaced the digitizer the first time and got nothing on the display, reseated the connections and still nothing. I swapped it out with another digitizer and this one worked fine. Unfortunately the lock button was not working. I found this odd since the volume buttons are still functioning normally.

I have tried reseating the lock button, and verifying that it is indeed pushed up and inserted correctly into the back housing of the device, and that it is making a solid connection with the flex cable at the contact point.

I have also checked the flex cable itself, tracing it with a pen light from lock button to volume buttons and then to the solder points on the logic board, but I cannot find any visible damage or tearing to the flex cable.

I am hesitant to solder a new flex cable on since the volume buttons are working, and I cannot see any damage to the flex cable.

Is it possible that the power button could still not be making the proper connection? I have done everything I can think to do, like removing the screw securing it in and then pushing the lock button up into the correct position with a plastic spudger, I also made sure that the small metal piece securing the lock button is tightened down properly, and that it is clicking when depressed against the flex cable.

I just can't think of any reason it would stop working, other than possibly a short in the flex cable. Any ideas or advice would be appreciated.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment