Skip to main content

Replaced DC-Inboard, but now battery won't charge, what's the prob?

So I just replaced my DC-Inboard. My computer works great and worked perfect the first day. The battery charged, the light on the adapter was green, everything was great. The next day, there was no light on the adapter and the battery would not charge. The computer showed that it recognized the plugin, and would run on just the adapter. When the computer is asleep, the adapter light is orange and the battery charges.

I went to my local mac fixer and we tried out a new battery and adapter with the same results.

I've tried resetting the SMC and PMU. Nothing changed.

Did I mess something up on the logic board or on the DC-DC board? I tested the continuity of the DC-Inboard, those wires were ok.

Then I took out the DC-DC board, I tested the continuity of the prongs that go into the battery to the prongs that go into the logic board. I only found the first, third, and fourth prong to the battery (left to right) have continuity on the DCDC board. The six prong is the ground.

I'm going to tear this thing apart again to see if it's something on the logic board that I messed up.

Does anyone have a diagram for the circuit board so I know where everything connects?

Any ideas???

Answered! View the answer I have this problem too

Is this a good question?

Score -1

What was happening before you replaced the DC IN board?


I had tripped over my cord and ruined the pins inside the DC-board where the adapter plugs in.

The odd thing is that it worked fine the first day I replaced the DC-Board.

The other odd thing is that I can still charge my iPod Touch through the usb port (while not in sleep mode) and I can fully charge my battery as long as it is in the sleep mode, yet the light on the adapter is orange.

I have a feeling I fudged some connection point during the repair.


Tell me about your AC charger. Frankly it sounds like it is the wrong voltage.


It's definitely not the charger.

I tried a new apple charger at the store, an older apple charger my friend has, and the new after market charger that I bought and now am using since i also messed up my original charger. Thanks though for the idea.


I noticed you never got an answer to this. Are you still having this problem?


Add a comment

1 Answer

Chosen Solution

So my problem self corrected about a few months after I replaced the dc-inboard. The battery charges just fine and all is good. My assumption is that I may have dirtied the prongs on the dc/dc board with some residual thermal compound or whatever. I don't think it's a loose connection anywhere since when it corrected itself I've never had a problem since. I take this laptop everywhere, abuse it, and it still is working just fine. Maybe some weird static buildup interfering with a connection? Who knows.

Was this answer helpful?

Score 1

1 Comment:

Glad it got fixed, be sure now to mark the answer as accepted.


Add a comment

Add your answer

maruskiewicz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,645