Model No. A1367 / 8, 16, 32, or 64 GB capacity

1269 Questions View all

Two rows of touch do not work after repairing Home button

Hi,

The home button on my iPod touch 4g was stuck down so I opened the case to fix it. Now it works fine but when I turned the iPod back on, I realized that one row of touch did not work. It then expended to the last row as well after I tried to reseat the LCD cable. Then I disassembled the iPod some more to disconnect the digitizer completely and reconnect it. Same thing. The two last rows don't work. The digitizer cable does not seem damaged and I was VERY cautious during the whole process. Is it possible that I broke the digitizer itself? Is there something else I should try? If I order a new screen will it fix the problem?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

I booted the iPod in recovery mode. I'm performing a full reset at the moment and if it doesn't work, I buy a new LCD+digitizer hoping that it will work...

by

Same problem after full reset. I bought a new screen on Amazon. We'll see how it turns out...

by

Add a comment

2 Answers

Chosen Solution

Buying new digitizer could fix the issue.

Was this answer helpful?

Score 2
Add a comment

Try to clean contacts of digitizer with alcohol, I did it with my iPad and it helped)) but be careful

Was this answer helpful?

Score 0
Add a comment

Add your answer

Matthieu Pepin will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 431