Installed Superdrive not working

I installed an ifixit MacBook 6x Superdrive in my MacBook Pro 15" 1.83 Ghz Core Duo and when finished, the drive accepted a CD disk but is not recognized by my computer. I am pretty certain the installation was correct so I'm wondering if I need a firmware update or what? Any suggestions would be appreciated. Thanks - Kevin

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

The old dvd/cd drive was recognized by the computer but had gotten to a point where it would not read disks. I think the newly installed drive is getting power because it accepted the disk I put in (when I tried the same with the drive I had removed, it would not accept it), but that is as far as it went. I now can't eject the disk because the computer is not recognizing the drive. I don't know the exact drive model but it is one of the 6X Superdrive offered by ifixit for the MacBook Pro 1.83 Ghz core duo model A1150. I am running system 10.4.11 and have tried repairing the hard drive with disk utilities (no problems there), resetting the PRAM and resetting the SMC and still no success. Also when I run the System Profiler > Disk Burning it says no disk burning device found.

by

Definitely a superdrive. Just received another one from ifxit and we'll see if it's the drive or cable.

by

Add a comment

2 Answers

Chosen Solution

Was your old drive recognized by the computer ? If not I would suspect a bad optical drive cable. Does the drive get power from the computer ? What is exactly the drive model ?

Was this answer helpful?

Score 2

Comments:

good thinking +

by

Add a comment

What system are you running? Have you updated your system software?

Try each of the following steps in this order before you reset the SMC. Test the issue after completing each troubleshooting step to determine if the issue still occurs.

Press Command + Option + Escape to force quit any application that is not responding.

Put your Mac to sleep by choosing the Apple () menu from the upper-left menu bar and then choosing Sleep. Wake the computer after it has gone to sleep.

Restart your Mac by by choosing the Apple () menu from the upper-left menu bar and then choosing Restart.

Shut down your Mac by by choosing the Apple () menu from the upper-left menu bar and then choosing Shut Down.

If your Mac appears to be running normally but isn't responding, force the computer to shut down by pressing and holding the power button for 10 seconds. Note: You will lose any unsaved work in any open applications.

For Mac portables experiencing issues related to the MagSafe power adapter and/or battery, try:

Unplug the MagSafe power adapter from the Mac and the wall power socket for several seconds.

Shutdown the Mac. Physically remove and re-insert the battery (if it's removable) and startup the Mac.

If the issue is still not resolved after following the troubleshooting items above, an SMC reset may be necessary.

After performing normal troubleshooting, these symptoms may indicate that an SMC reset may be necessary:

Resetting the System Management Controller (SMC)

Resetting the SMC on Mac portables with a battery you can remove

Note: Learn about removing the battery on MacBook and MacBook Pro.

Shut down the computer.

Disconnect the MagSafe power adapter from the computer, if it's connected.

Remove the battery.

Press and hold the power button for 5 seconds.

Release the power button.

Reconnect the battery and MagSafe power adapter.

Press the power button to turn on the computer.

Was this answer helpful?

Score 1

Comments:

Did you have a combo drive rather than a superdrive. Here's the cable for the superdrive: MacBook Pro 15" (Model A1150) SuperDrive Cable

by

Add a comment

Add your answer

kevin will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 7

All Time: 2,523