Model A1181 / 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1356 Questions View all

cannot upgrade from osx 10.4 to anything!

Hi,

I brought this macbook a couple of years ago. It came with osx 10.6 but once the hardisk fail I have to reinstall it and the dvd was corrupt. I tried a lot of Osx retail dvd but I always get an error during the installing (you know, error messages in Osx install doen't give any details about the problem, just ask you to reinstall all over again).

The only one that worked was an 'old' Osx Tiger 10.4 I had from my iMac. It worked, but all try to upgrade to 10.5 or 10.6 gived an error during the installing (I burned a lot of DVDs dual layer in several machines, I also made some booteable usb devices... even my old iMac upgraded from that 10.4 to a 10.6.something only by executing the dmg file).

You know what can be the problem? This machine is from 2007 and originally camed to me with an snow leopard installed that worked fine. The Cdrom drive also works, as it installed right the 10.4...

EDIT: ITS AN A1181, I WAS SURE I WRITE THAT BUT...

Thanks in advance!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Do you have a retail version of the 10.6? Are your 10.6 disks gray?

by

Add a comment

1 Answer

Chosen Solution

Start by IDing your mac - generic Answers are no more helpful than generic Questions''.... too many variables.'' Once we volunteers know more about hardware we can offer some helpful Answers.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1

Comments:

sorry I had writed down the model in the 'device' part but it seems that its not shown in the message. Its a macbook A1181L

by

If the install is failing I suspect your HD. Use Menu->Tools->Disk Utility off the install disk to Repair the HD. If that fails try to reformat the drive. If that fails the HD is shot.

by

I tried in at least 2 differents HD in this machine. Its some kind of undefined error most of the time near to the end of the instalation. At first I though that was because I where using not retail Snow Leopard distributions, but I also tried with some files downloaded from the net and well verified and nothing worked..

by

Well yes if you are trying to install a version of the OS designed for a SPECIFIC machine it will fail, but generally out the door it will tell you it won't work. Are either/both of the HD's new or "known" good hardware e.g.Were you able to install to these HDs in other machines, with other OS's? IF NOT I go back to suspecting damaged HD's. I've seen this a lot with failing/damaged HD's the install tries to write to a damaged sector and poof - you're done.

by

The hd never gived any error with Disk Utility or Techtool Pro. Actually I had no problems to install the 10.4 tiger on it, its the only thing it works...

That Tiger its ALSO not a retail version but a one who comes with my 2006 20" Imac, where I was able to upgrade to Snow Leopard without any problem.

I really don't understand, because I used like 10 differents versions, both in dvd as in pendrives or images mounted.

by

Add a comment

Add your answer

mjm will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 521