0

Score

Avatar
mrfoot51
1

Asked

Hard to start, after running a while.

History

My wife has 2006 altima that she uses daily only about 10 to 12 miles a day. After the car runs for 15 to 20 minutes and sits for 15 to 30 minutes it is very hard to start. The gas has to be pumped and turn over the engin and car will finaly start. This is not normal. my question is could it be the fuel filter or more likely the pump or something else. The service engin light stays on also. The car has 60000 miles on it.

Edited by: mayer ( )

Add Comment Cancel

Post Answer

2

Score

Avatar
oldturkey03
212.9k

Answered

Accepted Answer

PermalinkHistory

mrfoot51, any way you could get Autozone or any of the other places to run a diagnostic scan on it? It does sound like the fuel pump/ pressure not acting right.

Add Comment Cancel

1

Score

Avatar
HemiBill
1.6k

Answered

PermalinkHistory

The first step in diagnosing any computer controlled vehicle is to check the computer's memory for a diagnostic trouble code. The check engine light being on is an indication that there is a DTC stored.

The symptom of hard starting after sitting for a short time could be a fuel system related component. If you have a leaky fuel injector, that would cause re-start problems.

Add Comment Cancel

0

Score

Avatar
jerasmus
1

Answered

PermalinkHistory

ECT (engine coolant temp sensor)

the ECT responds to change in coolant temp. by measuring the the coolant temp, the ecu knows the average temperature of the engine .

the ECT sensor is needed to controll many functions such as fuel injection, ingnition timing,variable valve timing, transmisions shifting ect.

Add Comment Cancel

0

Score

Avatar
kyle
1

Answered

PermalinkHistory

camshaft and crankshaft position sensors just had the same problem with my altima

Add Comment Cancel

Add Your Answer

View Statistics:

Today: 0

This Week: 0

This Month: 1

All Time: 1,820