How to repair loose connection in iGhost iPod Docking Station?

My daughters iGhost docking station seems to have a faulty connector, it plays fine if the ipod is pushed forward slightly.

I have taken it a part however cannot see anything obvious, does anyone know where I can get hold of a repair manual for this so I can get some idea of what to look for.

Many thanks

Brian

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Sounds like the solder under the connector (or attaching it to the logic board) is cracked. Soldering these parts requires special solder and equipment and it's easy to destroy the logic board. SOMETIMES if you can smear some flux around the join and apply heat it will "reflow" this is a temporary repair as solder is brittle like any metal and can scale with heat. You might try placing a USB A male-female cable in the slot and taping/gluing it down so the connection is solid. This would give your daughter something else to hold/attach her iPod to and possibly extend the use of the unit.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 2

Comments:

Thanks for the advice, I will try your suggestion regarding glueing a cable in the slot, will let you know how I get on

by

You're welcome and good luck!

by

Add a comment

Add your answer

Brian will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 5

All Time: 1,469