Model A1181 / 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1356 Questions View all

No audio, no mic

I have lost all audio function on my late 2007 MBP 15" Duo 2.53 GHz including the microphone and startup chime. I have tried every online fix and reset (PRAM),(SMC) I have restored the system 3 times OSX 10.5.8 and toothpick probe etc.....I was using the computer with external speakers for years with zero issues. Shut it down at night as usual and then next morning all sound was just gone. Here is the weirdest part. In audio midi setup my MBP says internal stereo output is not supported but I can route my MBP through firewire to a digital i/o box that has no sound card. I route to the external firewire device and all sound is restored through firewire i/o device headphone output! WHAT? That means my MBP is still putting out sound does it not? I am using this workaround for now but I would greatly appreciate any advice. I am known to be somewhat tech savvy but this one has me gobsmacked.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

To me it would mean your audio ports are damaged. There is no separate sound card for this laptop. Get USB audio adapter. It would be easier, cheaper, and work as well as replacing the logic board. You probably also have sound off the HDMI port... trying to fix/replace an audio port is not really IMnsHO a DIY repair.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Andrew Kavadas will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 657